Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Strange FPS in Kingdom Hearts
#1
Hi guys, I have a strange problem. The game runs fine at 60fps most of the time, but it goes down to 40-50 in the press start menu, and some times during the game, in random areas. I tried the latest revision and the PCSX2 1.0 stable version.
PC Spec:
Core 2 Duo E5400 2.7ghz
Ati Radeon HD 5670
2gb Ram
Windows 7 32bit

Settings:
Revision 5689
Video: GSdx SSSE3, Resolution makes very little difference, DX11 Hardware
Sound: SPU2-X
Speedhacks: EE set to 1 and Vu set to 1

Thank you in anticipation ^^!
Reply

Sponsored links

#2
Its normal according to ur cpu power..
Reply
#3
What are your EE and GS (and VU if using the mtvu speedhack) % values during the slowdowns?
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#4
In the main menu EE: 24%~27% GS:95%~98%
During the stages EE and GS : 40%~60%
Reply
#5
(06-30-2013, 08:52 PM)Sonikko Wrote: In the main menu EE: 24~27 GS:95~98
During the stages EE and GS : 40~50

Seems like a GPU bottleneck. It's a bit common for games to lose frames like that in menus, an example being Monster Rancher 4, which can run flawlessly on turbo mode but falls to 50 fps whenever the monster menus open, likely due to complexity.

Not much you can do to improve the situation. Either you live with it, or tinker with the speedhacks to try and bump the playable speed up to a level where you won't notice a slowdown. Try raising the VU cycle stealing to 2, see if it helps. Be warned that the fps reading may be falsified.
Reply
#6
Thank you all for the answers, but I was asking because I didn't remember it slowing down this much the last time I played it xD!
Reply
#7
Low EE but high GS shows that maybe you are in software mode. Try pressing F9 or double-check your plugin settings to make sure you are in hardware mode. As miseru will kindly point out the GS is still a cpu function. Low EE and GS together with decreased fps point to a weak gpu.

So also make sure you decrease your resolution, possibly to native, to see if that helps.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#8
I'm in hardware mode, and drecreasing the resolution doesn't help, so I thought it wasn't a GPU problem!
Reply
#9
Then it's a cpu problem.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#10
Have you enabled any other Speedhacks though?

MTVU might help in stages, but may not help in menus.
Or you could try setting VU to superVU1 instead.

Oh--
and when was "the last time" you played it?
Older PCSX2 version? Cleaner OS..?
Anything you can think of that has changed...?
I'd like to think I shouldn't have to ask if you are using the very same set up and settings...
Reply




Users browsing this thread: 1 Guest(s)