Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Strange Pixels in Nocturne and OPENGL
#1
First of all, thanks this community for the effort done to make each of the ps2 games close to perfect emulation. I love playing some of the ebst PS2 games with great resolution.
I am trying SMT: Nocturne and i've found that this is one of the tricky ones. I'm using Opengl because with dx11 hw i found quite a lot of texture bugs, like seeing through walls. In opengl hw, all seems working fine except that awful diagonal line. What do you think i can do to solve it?
PC specs: I5- 6500  AMD RX 480 Tell me if you need any more info or logs, i attach some screenshots with my pscx2 config and the weird pixels

Thank you!

Edit: I'm using the last automated pcsx2 build


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
Open your window, unplug your gpu, throw it, buy an Nvidia GPU. Problem solve!

Maybe you can try to disable geometry shader (I'm not an home so I can't post the config)

Or higher accurate blending
Reply
#3
(01-15-2017, 12:30 AM)gregory Wrote: Open your window, unplug your gpu, throw it, buy an Nvidia GPU. Problem solve!

Maybe you can try to disable geometry shader (I'm not an home so I can't post the config)

Or higher accurate blending
I suggest powering down and unplugging the PC first. Tongue
Reply
#4
(01-15-2017, 12:30 AM)gregory Wrote: Open your window, unplug your gpu, throw it, buy an Nvidia GPU. Problem solve!

Maybe you can try to disable geometry shader (I'm not an home so I can't post the config)

Or higher accurate blending

When they get cheaper, I will Biggrin Where can i found the geometry shader option? Tried changing the accurate blending, but nothing changes.
Edit: I added this line (override_geometry_shader=0) in the ini config of gsdx and still the same.
Reply
#5
First of all make sure your drivers are up to date, beyond that, you might be screwed Tongue

I'm afraid I don't remember the option for the geometry shader, but it will be a line you put in the gsdx.ini file.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
(01-15-2017, 01:38 AM)refraction Wrote: First of all make sure your drivers are up to date, beyond that, you might be screwed Tongue

I'm afraid I don't remember the option for the geometry shader, but it will be a line you put in the gsdx.ini file.

Yeah! I always keep them updated. Is that line override_geometry_shader=0 ?
Reply
#7
yeh sounds about right Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#8
Check the log message.I think it will tell you if it is disabled
Reply
#9
For the same level of performance, prices of both vendor s are rather close. However, you always need to wait months/years to have a working driver. (I deals with gl here, don't use DX)
Reply
#10
(01-15-2017, 09:25 AM)gregory Wrote: For the same level of performance, prices of both vendor s are rather close. However, you always need to wait months/years to have a working driver. (I deals with gl here, don't use DX)

In my country, the 1060 6gb was 70€ over the 480 4gb. The 3gb version was around 20-30€ more, but it's underclocked and 3gbs... it would be outdated by this year.
I finally made it work good on the 1.4 stable version, with the line about the geometry and blending unit accuracy to none. That last config seems like the one solving the diagonal line. The problem i found in the last 1.5 build is that, after the video cutscene of the game, if i have the blending accuracy to none, the entire program crash. And I can't see anything in the log because... well, it crash too, not leaving trace of what is the problem.

May be the demons demons leaving the game?
Reply




Users browsing this thread: 1 Guest(s)