Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Strange problem with my emulator
#1
Hi everyone.

I've encountered a strange problem with my emulator when i play god of war. The game runs fluently just when i start it up, or if i have put the computer into sleep with the game open. But after about 5 minutes it goes down to about 30 fps. Normal speed is 60 fps. I have no idea, why this occures.
I have setup my emulator as described here:
http://forums.pcsx2.net/Thread-Sticky-Co...tion-Guide

My laptop stats:
Intel Core 2 Duo 2,5 GHz (I know it might not be enough, but the game runs fluently sometimes?!!??!?)
Graphic card: NVIDIA Geforce 9500M GS,
Ram: 4 GB
OS: Windows 7 Ultimate 64 Bit

My emulator is setup with the following plugins:
GS: GSdx 4600 (MSVC 15.00, SSSE3) 0.1.16
PAD: LilyPad svn (r4510) 0.10.0
SPU2: SPU2-x r4600m 1.4.0
CDVD: cdvdGigaherz (r4510) 0.8.0

Speed Hacks:
EE Cyclerate: 3
VU Cycle Stealing: 2
INTC Spin Detection: Enabled
Wait Loop Detection: Enabled
mVU Flag Hack: Enabled
MTVU: Enabled

My video plugin is renderet to Direct3D9 (hardware), none Interlacing. Resolution is set to Native.
SPU2-X is configured as following:
Interpolation: 0
Disable Effects Processing: Enabled
Reverb Boost Factor: 1X
Module: 1.XAudio 2
Synchronizing mode: TimeStretch
Audio Expansion Mode: Stereo

Lastly i am using the latest version of PCSX2 1.0.0

I hope somebody have an answer to my problem.

-schendu
Reply

Sponsored links

#2
How can you know you get 30 or 60 fps since you are using so many speedhacks ?

Yes your cpu is a quite weak, but you gpu is really weak for pcsx2. And i have the feeling this will be tour bottlneck for most parts of the game.

Did you set your windows power plan to performance mode ? Are you running on batteries ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Your graphics card is extremely weak, it's possibly running out of video memory.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
Ok thank you for the responses Smile The fps i can read from the top of the window, when the game runs. But the strange thing is that it runs without problems for 5 minutes, and then all of a sudden it starts lagging, where the fps drops to 30.
And i know that i use many speed hacks, but it is the only reason the game is even slightly playable..

This picture shows where i read the framerate. I can try to make a video of it too, if that maybe helps understanding my situation Smile
[Image: 1zob5ls.jpg]

-schendu
Reply
#5
can you post a picture of the window when it goes slow? preferably so we can see all the values in the bar at the top.

Also to note, you are using the MTVU speedhack which is designed mainly for CPU's with 3 or more cores, as you only have 2 it may actually yield a performance decrease, so id suggest playing with that.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
(10-08-2012, 11:14 AM)schendu Wrote: And i know that i use many speed hacks, but it is the only reason the game is even slightly playable..
schendu

Sure, but when using those speedhacks, fps counter is faked.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
[Image: jpbkox.jpg]
Here

-schendu
Reply
#8
as i said, so we can see ALL the values.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
Oh sorry :I
I feel so noobish now -.-'

Fast
[Image: 1pjpdl.jpg]


Slow
[Image: sqnhwo.jpg]
Reply
#10
Looks like it probably is just down to your system. God of war is quite demanding, so you will have to probably upgrade your machine to get decent speed.

2D scenes (the fast ones for you) require little processing, which is why you're getting full speed.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)