Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Stuck at 50% fps
I've been using pcsx2 for many years, through it's various updates and evolution. Never once have I had a problem.

Recently my fps rate has been stuck at ~30fps (50%) while playing the ntsc game Monster Hunter 2.

I have used this game countless times before with no trouble. I have no idea what changed, I have tried every speed hack, frame skip and adjustment that I can think of via the emulator, all with no results of any kind.

The only thing that seems to work is setting the frame rate to no limit, which in turn shoots my fps to well over 150fps (which of course is useless in a 60fps ntsc game).

My processor and graphics card are all of a level that this emulator has never once given me the slightest hint of a problem.

While I am tempted to simply return to my console to play... the emu is just so much more convenient.

Current settings on the emu: Pcsx2 0.9.6
Graphics: GSdx 890 (MSVC 15.00, SSSE3) 0.1.14
CPU: all left tabs checked and as stated before, all frame limiting seems to have no effect.
Speed hack: set to the default currently, also seems to have no effect.

Processor: Intel core2 duo e8400 3ghz
Video care: nvidia geforce 9600 GT (512mb)
OS: XP 32bit
RAM: 4gigs (although 32bit chops that down)

I can provide any other info required.
Any and all assistance is extremely appreciated.

Sponsored links

You're not using vsync by any chance are you?
Nappa: Vegeta! What does the scouter say about his power level?
Vegeta: It' thousand and six.
Nappa: Wh-...really?
Vegeta: Yeah! Beat him up Nappa!
Nappa: Yay!
I am embarrassed to say, I do not know.

How would I check?
My mistake, were you referring to the wait vsync tab in settings?
If so, no it is currently not checked.
The behavior you mention is usually caused by enabling Vsync in GSdx or your graphics card control panel, could also be you changed the custom limit fps in cpu options in PCSX2. Show us all your settings so we can help better.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
[Image: im8pdw.jpg]
Looks ok, try changing the Custom FPS limit for your game to 60 manually, and make sure the Vsync option in your graphics card control panel is turned off too.

Also it may not be related at all but trythe latest beta:
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Thank you.

A simple change to the vsync setting on my graphics card (how foolish I must look).
The problem is completely resolved.

Although, I wonder why I never encountered this issue before.
I've never had altered the vsync on my card, only though the emu.

Once again, thank you, both of you.

Users browsing this thread: 1 Guest(s)