Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Stuck at 50 fps on NTSC game
#1
I have not been able to find an answer to this elsewhere yet...
I'm playing an NTSC copy of Ar Tonelico.
For whatever reason PCSX2 is capping my fps at 50 as if i'm playing a Pal region game, ... except it's not, so everything is a little slow. It's not my PC because i'm running a beast and the FPS is steady right around 50 as if it's being capped.

I can make the game run at 60fps by setting frame skipping on, but then it gets all choppy and any of the menu related game content glitches pretty bad. : |

I don't know what i'm missing here..
thanks for any help.
Reply

Sponsored links

#2
Pc specs? And what do your EE, GS and VU %s read (in the title bar)
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#3
Emulation settings >> GS tab...make sure your base framrate is set to 60fps for NTSC game.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#4
(06-12-2013, 03:51 AM)Dante3hs Wrote: Pc specs? And what do your EE, GS and VU %s read (in the title bar)

GTX 660ti with an i5 processor clocked over 4ghz (24gigs of ram)
> With frame skip <
EE 21%
GS 9%
VU ... ? i see UI: 0%

> No frame skip <
about the same.

Base framerate is 59.94 for NTSC.
I also tried going into the ini and changing Pal to 59.94 but it was still 50 flat, so i changed it back.
Reply
#5
VU only appears if the mtvu speedhack is active. You could try activating the recommended speedhacks, they shouldn't be necessary but may help with thjs issue.

What are your current gsdx settings? From those values it would suggest your gpu struggling, but with your gpu I doubt that would be the case.
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#6
I've tried activating the speed hacks as well and nothing.

My settings are Direct 11 hardware
Interlacing auto
Scaling 6x
AAx16
Texture filtering

I've tried turning everything down to low though as well, and Direct 9, or software.. basically every combo i can think of and it hasn't made a single frame difference from 50 flat. o.O?
Reply
#7
Out of curiosity, what fps do you reach with frame limiter off?
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#8
If you use turbo mode, does it improve your FPS or is it still hard-capped at 50?
Reply
#9
No change.
50 becomes 50, and 60 becomes 60.
Reply
#10
(06-12-2013, 04:25 AM)KetchupT100 Wrote: If you use turbo mode, does it improve your FPS or is it still hard-capped at 50?

That was going to be my next port of call. If disabling frame limit gets you over 60 fps, try setting turbo to 120% and enabling it.
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply




Users browsing this thread: 1 Guest(s)