Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sudden frames speedup, can't limit them.
#1
Hi, I'm new here.

I've been testing the emulator for a while and it has worked wonders so far, except by the fact it's sometimes faster than I want (more than 60fps) and everything moves too fast, but I've tried limit them and I can't do it, since the option at the GS core screen is gray and can't change it.

The NTSC and PAL frame limit are set at 59.94 and 50 respectively, though, but the game keeps running over 70-96fps sometimes, when there are not many objects to process.

What can I do?

Thanks in advance.

   
Reply

Sponsored links

#2
Try hitting the F4 button.
Reply
#3
I thought that just removed the frames limitation (the opposite from what I need), but I'll give it a try.

EDIT:

Indeed, that Key removed the limitation, making my problem even worse.

What I need is to set the frame limit permanently to 60 (or any number I want) without allowing the emulator to bypass that limit (as it sometimes happen when there are few objects to process, like Silent Hill 2 while flashlight is deactivated = No shadows)
Reply
#4
My bad. I looked again at the screenshot and noted it was off to begin with. Possibly a bug making it go too fast? Mine never goes above 60fps average so I'm not sure why this is happening.
Reply
#5
Are you hitting the tab key by chance? As that activates Turbo mode which as you can see increases the FPS.
Reply
#6
(12-24-2012, 08:05 AM)Topken Wrote: Are you hitting the tab key by chance? As that activates Turbo mode which as you can see increases the FPS.

No. As I stated before, it has really high framerate when there are few objects to process, like no shadows or fog absence. it's normal when those elements are present.
Reply
#7
TAB toggles between turbo (defined in your screenshot as 200% speed max) and normal (59.94 FPS for NTSC or 50 for PAL). So pressing TAB once should get you to turbo mode, and pressing it once more time should bring you to normal speed.

The title of the game screen (just left to "FPS: ...") should say Limiter: Normal or Turbo or None. Press TAB until it says "Limiter: Normal", which would limit the FPS to 59.94 (or 50 for PAL).
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#8
are you using any speedhacks? They can distort FPS
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
No. Guys, I'm telling you that FPS get really fast when there are simple processes on the go. As soon as a light that generates shadows or fog or effects like those are present, FPS go back to normal.
Reply
#10
(12-26-2012, 12:58 AM)Stoneheart Wrote: No. Guys, I'm telling you that FPS get really fast when there are simple processes on the go. As soon as a light that generates shadows or fog or effects like those are present, FPS go back to normal.

Which can be a perfectly normal behavior when limiter is not enabled.

- What mode is the limiter at (title of the game window)? "Turbo" or "None" may exhibit the behavior you describe. "Normal" should not.

- Do you see the FPS counter (at the title of the game window) go up? to what rate (61 fps? 70 fps? 90 fps?)? for how long (half a second? few seconds?)?
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply




Users browsing this thread: 1 Guest(s)