Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Suikoden III Does it Work?!
#1
Hi! Smile
So, I have been checking in on this wonderful site every 6 months or so, to see if Suikoden 3 works good now.
The problem I had 6 months ago was the FPS rate was like 10 instead of 50 so Suikoden 3 was unplayable. So I decided to wait.

So, Does Suikoden 3 work now? I mean is it Playable and have normal FPS? because 10 FPS is not really playable :-)

Any1 who got it to work with the new version?

Cheers

Sponsored links

#2
Some people have played Suikoden 3 at full fps (and it is playable) but you need to post your system specs before you can even think about playing it at a fast speed Tongue2
#3
Just tested it. It works perfectly fine, though you'd have to say what computer specs you've got.
Using a Core2 E8500 @3.16 and it's around 45-50 on NTSC.
#4
System Specs:

Intel Core Duo 2.13GHz
RAM : 2.0gb
Graphic Card = Asus 8800 GT ( I think )

Do you think it will work?
#5
(03-03-2009, 02:30 AM)Earthbound Wrote: System Specs:

Intel Core Duo 2.13GHz
RAM : 2.0gb
Graphic Card = Asus 8800 GT ( I think )

Do you think it will work?


The game is working fine on my system.
40+ fps average with default settings using Gsdx video plugin.

If I enable x3 Cycle Rate Speed Hack, I get an easy 80fps average.

Very minor graphic corruption under both configs (just minor graphics overlapping mostly on character's hair and helmets).

Aside from that, the game runs perfectly.

My Specs:
Intel Core 2 Duo E6700
2GB DDR2 9600 HyperX Ram
Geforce GTX 260 OCX Maxcore.
Win XP SP3

So I guess the game will run just fine under your specs. Just be sure to enable speed hacks. Also if you want an additional kick in speed, use SPU2-X plugin for sound, and disable effects processing.

Good luck.
#6
It might run fast enough now with "Denormals are Zero" enabled by default and working. This is one of the games you'll see major and I mean major speedup (100%+) from enabling Denormals are Zero which is located under "Advanced" but it's enabled by default so you shouldn't have to worry about it. So at least you should be able to get a lot better speed and enabling the other speed hacks might gain you some speed as well but if it's running fast enough still comp I'm not too sure, I'd say maybe 40 fps is possible at least if all the hacks are used.
Intel Core i7-860 @ 4.0 GHz | G.Skill 2x2GB @ DDR3-2290 9-10-9-24 | GTX 460 1GB @ 880/1760/2000 MHz | Windows 7 x64 Professional
#7
i had tryed this game a few versions back and at that time it was said unplayable from some people

am2+ quad core 9950 overclocked to 3.0 from 2.6
4G of ddr2 1066 ram
and a 8600 GTS card
windows vista x64

do you think i would be able to get it working and if so could you give me settings for what gfx plugin should be use and set up to?

thx ahead
#8
(03-03-2009, 03:27 AM)stalthnox Wrote: i had tryed this game a few versions back and at that time it was said unplayable from some people

am2+ quad core 9950 overclocked to 3.0 from 2.6
4G of ddr2 1066 ram
and a 8600 GTS card
windows vista x64

do you think i would be able to get it working and if so could you give me settings for what gfx plugin should be use and set up to?

thx ahead


LOL! With your processor, you could run this game 5 times over!
Your video card is pretty low spec, but I'm guessing this emulator depends so much more on CPU than GPU.

For graphics settings, I use GSDX 890 SSSE3.
Windowed at 1024x1024 resolution under Pixel Shader 3.

So go ahead. You've got more than enough firepower there.

Remember that speed hacks can double this game's FPS in case you're not getting the maximum already.
#9
See, I cant use ssse3 cuz that's a intel cpu setting my cpu dos not use that or sse41 so i don't get the best out of the cpu with this emu the thing that i worry more about is my card its not really that great my card only has 256 ddr3 ram not dual channel so i think that's where I'm bottle necking.

Edit: i also haven't tried this game in a while. I tried it way back before the speed hacks were even included.
#10
I'm getting around 200 fps on average no dx10 highest aa/rendering settings with some speed hacks. goes down to 150 fps, which is still 200% gamespeed during battle. It's ridiculous

e8400 @ 4.05ghz

evga 260gtx c216




Users browsing this thread: 1 Guest(s)