Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Super Lag
#1
Hello everyone,

I began using pcsx2 two days ago. I finally got it working properly last night. While fiddling around with the options trying to figure out how to get it working, i had one main issue. I was getting 5 to 6 FPS max (starting from the moment the emulator started).

Finally last night though I read through the guide and changed the settings accordingly, and it ran smoothly. 60 FPS from when the emulator started, all the way until I turned off the game I was playing 3 hours later.

This morning I turned on my CPU to find that I am back to a whopping 5.67FPS. None of the settings have changed, and I am curious why this may be happening.

my computer build;
Intel Core 2 Quad Q9550 Yorkfield
ASUS PQ5 Delux
4 GB of corsair DDR2 RAM
Radeon HD 4870

Having said that, I was thinking my processor is suspect since the clock speed drops when my CPU isn't doing anything. It idles at 2GHz, and only jumps up to 3GHz when something taps into it... Maybe the emulator isn't effectively tapping into my processor so it doesn't jump out of idle?
edit: just tried again while running CPU-Z, my processor is functioning properly...

any advice from the pros?
Reply

Sponsored links

#2
So yeah? are you running barbie sweet home or whatever? using ancient pcsx2? set some ridiculously high internal res on gsdx? should i call my personal ninja to found out?

And that is Intel speedstep, when situation demand it'll increase itself to the normal clock while in idle it'll underclock for power saving. It won't make any difference in game, normally.
Reply
#3
...or the settings you changed were never saved because you didn't right click->run as admin, or you put your pcsx2 folder in a folder which needs admin rights instead of a free one (i.e. my docs). and you're running Vista /7
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
(07-22-2010, 06:39 AM)naoan Wrote: So yeah? are you running barbie sweet home or whatever? using ancient pcsx2? set some ridiculously high internal res on gsdx? should i call my personal ninja to found out?

um?

windows xp. nothing has changed between this morning and last night, including locations of any files.

shin megami tensei 3, the pcsx2 version i downloaded from the official website two days ago. using the native internal res.

for some reason it won't start up in windowed mode to begin with. if i run the game in full screen mode (max setting) it works on the first or second try. after about 15-30 minutes of playing on that setting, i can switch it to windowed mode and it runs fine.
Reply
#5
the setting won't change if u don't touch them..
maybe there's something wrong with ur installation..
try reinstalling it and see if it works..

and what do u mean u run the game in fullscreen mode(max setting)?
for that go to Config>emulation setting>window setting..
untick the run in fullscreen mode..
see if that helps
[Image: 871087.png]

*Mio sees a ghost for the first time*
Mio: Aaaaaaah!! x_x
Seriously, the way she acts, you'd think she grew up with ghosts.
Reply
#6
Maybe some virus or background program eating all your cpu cycle? check task manager while you're running pcsx2 to see.
Reply
#7
after i got it working today i used it all day, working fine. gonna turn it on in the morning again tomorrow and see what happens.

i was pretty sure nothing was going on in the task manager, but i'll check again in the morning.

edit: woke up this morning and turned on my computer. loaded the emulator and sure enough it wouldn't run the game in windowed mode faster than 5 to 6 fps on the first two tries.

switched to full screen (highest resolution) and the emulator didn't do anything for a few minutes besides think so I closed it with task manager, then it worked full screen on my second try. after playing full screen for a while I was able to switch back to windowed mode.
Reply
#8
i experienced this 'open the emulator for the 2nd time and it works' problem..
perhaps problem is in the pc and not the emulator itself..
i forgot how i fix this..
[Image: 871087.png]

*Mio sees a ghost for the first time*
Mio: Aaaaaaah!! x_x
Seriously, the way she acts, you'd think she grew up with ghosts.
Reply
#9
In another thread was explained why the (my) Documents folder is misleadingly exempt of administrator flag. What happens in Vista and 7 is C:\Programs Files is treated with enhanced security what may lead to issues with many applications.

But the Documents is yet worse because only the actual user has access to it, that mean not even the administrator has directly (although the administrator can change access rights there, for example, he can't normally modify resources there before changing the access setup).

So, an application running under the "username" folder is not the user and this makes UAC or just the special folder normal security prevent it creating intermediate/temp files other than those it outputs as explicitly pertaining to and as being From the user.

The better is using a normal folder, not secured in any special way, such as C:\Games or D:\Emulators or whatever non protected folder, the name really does not matter. Vista and 7 introduced many "security features", some so dumb to the point disabling them actually improves security and we are yet learning those Windowses particularities and strangeness...
Imagination is where we are truly real
Reply
#10
yo,

nice idea. totally sounds like that would make sense so i moved all my stuff to a neutral place (c:\PS2stuff) like you said and i'm still getting the same problem.

anyway, it's not like anything is broken, i am still able to use the emulator after the first few tries.

i appreciate the help
Reply




Users browsing this thread: 1 Guest(s)