Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Super Robot Wars Z - Battle Scene Very Slow
#1
Hello, first of all here is my laptop's spec.
CPU Core2D P8400 @2.26Ghz
RAM 3GB
VGA nVidia 9600M GT
OS Win7 x86 Ultimate

The game in question is Super Robot Wars Z. Normally in-game (dialouge, menu, battle map) i get very good speed (90+FPS). Only when in the battle animation my fps drops to below 30 or even 15 in some very fancy attack (lot of explosions). I can pretty playing normally if i skip all the battle animation but it's not fun then.

I understand that my laptop is somewhat underpowered to emulate ps2 but is there any way to improve this situation? Thanks.
Reply

Sponsored links

#2
PCSX2 settings? Plugin settings? What do the EE/GS % numbers in the GS window say when you get slowdowns?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
i experienced this too on my laptop even it set in "native resolution",plugged in AC power and disabling windows aero

did you try to run in a desktop....my desktop's FPS drop very little about 50ish like the Big-O's large explosion attack.

another example is XAN in SRW-Z-special disc...i getting slowdown during XAN's timeline attack in my i7 laptop but my desktop survives it.

**EDIT**
alternately try using the DX9 renderer then DX10 in the GSdx....to check the FPS difference between DX9 and 10
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#4
I leave most settings at default as in the config guide except i untick all clamping. And no speedhacks. Gsdx ssse4.1 DX10. Native Resolution.

When i get slowdown the most, EE is about 40-50%, and GS is 15-25%.

And i found out that Allow 8-bit textures speed up the battle animations by at least 70%. I get 30 fps now instead of 17fps in the most intensive scenes. But its still too slow for my taste.

All other SRWZ threads I found, people got slowdown in the map which is the opposite of my problem.
@tallbender : Well yes my desktop is powerful enough to play at full speed but you can't carry it around Laugh.

Update : I get the battle animation at full speed (80+fps) by switching to DX9. But get a major slowdown (25fps - EE 30%, GS 15-18%) in the battle preparation windows (which appear alot).
Reply
#5
@dullahan29

i'm currently doing trial-error on my i7 laptop and here the possibilities you may try that.
in the speed hack menu.
enable Status flag Hack(if you're using 0.9.6)
enable mVU Flag Hack(if you're using 0.9.7)

**EDIT**
weapon of choice:Gundam X's Twin Sattelite cannon's battle animation


Attached Files Thumbnail(s)
       
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply




Users browsing this thread: 1 Guest(s)