Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tales of Destiny DC Help (freezing, laggy audio)
#1
Hi there.

So as the title says I am trying to play Tales of Destiny DC. The game will run but freeze during the intro. I can skip the intro and go into the game and it will run, but only at about 22-30fps and the audio is very laggy.

I've googled and run into threads here with people having the same issue with this game and fixes/help have been posted, however (and I really apologize for this) this is my first time using any emulator other than visual boy advance and combined with being generally computer dumb, most of it was Greek to me. 

TL;DR in layman's terms, what are ways for me to get this to run faster/better? (and, ideally, make it so I don't have to skip FMVs.) And again I apologize as I know this has been asked before.

Here's my pc stuff: http://i.imgur.com/nhU9XaC.png
Also I'm running windows 8. Thank you so much for your time.
Reply

Sponsored links

#2
(12-24-2015, 09:39 PM)majinken Wrote: Hi there.

So as the title says I am trying to play Tales of Destiny DC. The game will run but freeze during the intro. I can skip the intro and go into the game and it will run, but only at about 22-30fps and the audio is very laggy.

I've googled and run into threads here with people having the same issue with this game and fixes/help have been posted, however (and I really apologize for this) this is my first time using any emulator other than visual boy advance and combined with being generally computer dumb, most of it was Greek to me. 

TL;DR in layman's terms, what are ways for me to get this to run faster/better? (and, ideally, make it so I don't have to skip FMVs.) And again I apologize as I know this has been asked before.

Here's my pc stuff: http://i.imgur.com/nhU9XaC.png
Also I'm running windows 8. Thank you so much for your time.
Check to see if you're running in High Performance in Windows Power Options and enable MTVU Hack since you have more than 2 cores. If that doesn't work then upload your PCSX2 log.
Processor: AMD Athlon X2 6000+ 3.0Ghz
Video Card: ATI Radeon HD4650
Rams: 4GB
OS: Windows 7
Reply
#3
(12-25-2015, 12:32 AM)Frozen_Raven Wrote: Check to see if you're running in High Performance in Windows Power Options and enable MTVU Hack since you have more than 2 cores. If that doesn't work then upload your PCSX2 log.

Hi! I switched to this mode as you said and it seems to be running at a steady 35fps. The opening FMV still freezes but I can always skip it. However, the audio is still very laggy. Here is the log: http://pastebin.com/QDsS5vtf

thank you so much.
Reply
#4
It's still laggy because it's not running at full speed (60FPS). Try using the latest PCSX2 version (Might help the freezing but might reduce speed because of improved accuracy)
I don't own the game myself but you could try to enable the hardware hacks and set the skipdraw to 2 or more although that might screw with the graphics it could sometimes result in mild speedup with heavy scenes.
Also try enabling some speedhacks one by one and test to see if the speed becomes better, otherwise if that all doesn't work then I think that your laptop just isn't fast enough (2.5Ghz usually isn't fast enough) and need to continue playing on your ps2 unless you can handle the lower fps.
Processor: AMD Athlon X2 6000+ 3.0Ghz
Video Card: ATI Radeon HD4650
Rams: 4GB
OS: Windows 7
Reply
#5
(12-26-2015, 12:23 AM)Frozen_Raven Wrote: It's still laggy because it's not running at full speed (60FPS). Try using the latest PCSX2 version (Might help the freezing but might reduce speed because of improved accuracy)
I don't own the game myself but you could try to enable the hardware hacks and set the skipdraw to 2 or more although that might screw with the graphics it could sometimes result in mild speedup with heavy scenes.
Also try enabling some speedhacks one by one and test to see if the speed becomes better, otherwise if that all doesn't work then I think that your laptop just isn't fast enough (2.5Ghz usually isn't fast enough) and need to continue playing on your ps2 unless you can handle the lower fps.

So I booted it up again in high performance mode and it was running at 60fps. However now I cannot skip the opening cutscene and so it freezes there. The start button definitely works as I get past the company logos and stuff with it but for some reason it does not skip the opening anymore.

I'm sorry but I'm not sure what the rest of this means (hardware hacks, skipdraw, speedhacks). How do I do those? Thank you for all your help.

Edit: okay I got it to go past the title screen again by doing the full boot instead of fast. It is still running at 60fps but i worry about it slowing when getting to some of the more intense parts of the game.
Reply
#6
If you see slowdowns that disturb please not fps/speed, ee% and gs% values from the title bar.
Reply
#7
(12-27-2015, 10:15 PM)willkuer Wrote: If you see slowdowns that disturb please not fps/speed, ee% and gs% values from the title bar.

I'm sorry, what does this mean, like to not report slowdowns in fps/speed but in the other numbers from the title bar?

Also sorry, an unrelated question -- what is the best way to get a ps3 controller working on the emulator? Corded, not wireless, just because I assume that's easier. Also, is it possible to do it with multiple controllers (so, to have multiplayer).

Edit: i've been looking into it for a while and everywhere i see say to use that motionjoy thing but on the faq thread here it says that's full of malware. And I don't understand the instructions on the thread here especially since they seem to be related to using a bluetooth and i'm fine with just plugging it in.
Reply
#8
(12-27-2015, 10:23 PM)majinken Wrote: I'm sorry, what does this mean, like to not report slowdowns in fps/speed but in the other numbers from the title bar?

Also sorry, an unrelated question -- what is the best way to get a ps3 controller working on the emulator? Corded, not wireless, just because I assume that's easier. Also, is it possible to do it with multiple controllers (so, to have multiplayer).

Edit: i've been looking into it for a while and everywhere i see say to use that motionjoy thing but on the faq thread here it says that's full of malware. And I don't understand the instructions on the thread here especially since they seem to be related to using a bluetooth and i'm fine with just plugging it in.

What Wilkuer meant was most likely Note* instead of Not. In other words post your fps and the EE% and GS% which is shown at the title bar.
And the Hardware hacks are located in the Video GS plugin but should only be used if necessary (Which no longer seems to be the case now)
As for the issue with your controller I can't really help with since I use an Xbox 360 controller and works perfectly.
You can customize 2 controllers from what I saw but there is also an option for multitap But I never personally used it.
Processor: AMD Athlon X2 6000+ 3.0Ghz
Video Card: ATI Radeon HD4650
Rams: 4GB
OS: Windows 7
Reply
#9
(12-27-2015, 10:23 PM)majinken Wrote: I'm sorry, what does this mean, like to not report slowdowns in fps/speed but in the other numbers from the title bar?

(12-28-2015, 12:14 AM)Frozen_Raven Wrote: What Wilkuer meant was most likely Note* instead of Not.

Sorry. I meant 'note' as correctly interpreted...

For the controller there are different possibilities. You can use the tool provided in this forum (SCP ToolKit) which contains a nice manual in the first post. or something like BetterDS3. I would really not recommend MotionJoy.
Reply




Users browsing this thread: 1 Guest(s)