Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tales of the Abyss - Speeding up the voiceovers
#1
Hey there,
I just got a new, pretty powerful PC and I thought what better way to test its performance than running a last-gen emulator on it?

I've started to play Tales of the Abyss using Pcsx2 0.96 (the latest "stable" build, haven't tried any betas yet) and I'm about 20 minutes in. Using the default settings and plugins everything was playing pretty decently, except for one thing I've noticed that is just really annoying me.

Anytime I'm in an outside area the FPS drops to about 45. Alright, this is understandable. Along with the video, the audio slows down too. Again, this makes sense, and I normally wouldn't care, except for that if this occurs in a scene with voice acting, the voices will slow down too. It's just a little bit slower, but it is still noticeable and annoying as all HELL, enough to make me want to skip the scenes.

I really would like to enjoy the game with the voice acting in the scenes too, so I've been trying to optimize it however I can. Unfortunately I don't know what many of the over 9000 checkboxes do so for the most part I just toggle some settings, hit execute and test a scene, and repeat ad infinitum.

I don't care very much what the game looks like; if I could get the audio right, a little slowdown/choppiness in rendering is perfectly acceptable to me. Though I'd like to get it to run at 1024 width if possible since I run the game maximized, and when the resolution is native it just looks godawful when maximized.

I've tried frameskip at the default settings and it doesn't seem to make much of a difference in the audio. (Though it does make the game nearly unplayable due to how much back and forth skipping it does)

Here are my system specs:
Intel Core 2 Quad Q9550, clocked @ 2.83 (stock)
4 gigs of RAM
Crossfire 2xATI Radeon HD 4850
Integrated Audio (don't know if having a sound card would make a difference, I don't think it's a problem with the actual sound processing)
Vistax64

So ultimately my question is: Does anyone have any advice on how I can keep the audio running at the same speed even when the video slows down somewhat?


EDIT: I just tried the beta (using default settings) and it's the same. I also watched part of a YouTube walkthrough to make sure I wasn't just crazy and it's definitely slower in the emulator.
Reply

Sponsored links

#2
Hmm. Well, by using the beta build and beta SPU2-X plugin, and by enabling pretty much every speedhack that was available (x2 EE sync, INTC sync, IOP x2, WaitCycles, and "slight" VU cycle stealing) I was able to get the scene I've been testing up from 40 FPS to a near-constant 60 while still keeping the graphical quality near perfect. The audio is fine now, though there's still the occasional framerate drop every so-often that will slow it down for about a second.

I'm happy now, but if anyone has any further suggestions please post. Otherwise thanks for reading, and thanks Pcsx2 team for a sick emulator. Smile
Reply
#3
That sounds about right, maybe try ZeroSPU2 it may be faster on those slow scenes but most likely SPU-X will sound better anyway.
Reply
#4
Are you using dx10 hardware? Tales of the Abyss likes dx10 more than dx9. Also, graying out texture filtering might increase frame-rate.
Nappa: Vegeta! What does the scouter say about his power level?
Vegeta: It's...one thousand and six.
Nappa: Wh-...really?
Vegeta: Yeah! Beat him up Nappa!
Nappa: Yay!
Reply
#5
Huh, after trying seven or eight times to log in I realize I misspelled my username when registering.

@Dr_thrax:
Yep, I'm using Dx10 with h/w accel, forgot to mention that.
@Shadowlady:
I did try ZeroSPU with the same results, as well as SPUX with DirectSound. None of them made any difference, since the issue was caused by the audio (behaving as intended, really) slowing down to match the framerate.

Basically what I wanted to do was either: (1) get the audio plugin to ignore the framerate and run at its own speed (would lead to syncing issues but at least the voice would be okay). I sort of got this to work by checking an option somewhere but it was not usable because the audio would jump back after it realized it was too far ahead. Or (2) get the framerate to constant 60, either by skipping frames or tweaking speedhacks till my computer could pump out that many. Eventually the speedhack route worked.

After playing the game for a while, the speedhacks have indeed solved the audio problem but since I have so many of them enabled it seems to be hurting the stability; Pcsx2 crashes fairly often with Windows throwing a DEP notice. It's still very playable, however, since I savestate frequently.

So it seems like the way to solve the problem would be to use frameskipping to get the FPS to 60 without having to use speedhacks. This way the audio would run at full speed and the stability would be better since the hacks were off. If I could just get the frameskipping to work right... it seems like every time it drops a few frames, it draws the newest one, then jumps back to before the skip, and then jumps back again to the newest frame. Very distracting.

Still, the game is completely playable now even with the crashes, I'm mostly just continuing to look for another solution out of curiosity's sake.
Reply
#6
(06-10-2009, 08:21 PM)Anidamo Wrote: Basically what I wanted to do was either: (1) get the audio plugin to ignore the framerate and run at its own speed (would lead to syncing issues but at least the voice would be okay).

In this case P.E.Op.S Sound plugin does this if you uncheck the "thread mode" but you got it working now anyway Tongue

For the speedhacks just find which one is causing your game to crash, in fact using the search feature you may find a solution for those crashes. Usually speedhacks dont cause games to crash because of using too many but only 1 in particular.
Reply
#7
(06-10-2009, 08:47 PM)Shadow Lady Wrote:
(06-10-2009, 08:21 PM)Anidamo Wrote: Basically what I wanted to do was either: (1) get the audio plugin to ignore the framerate and run at its own speed (would lead to syncing issues but at least the voice would be okay).

In this case P.E.Op.S Sound plugin does this if you uncheck the "thread mode" but you got it working now anyway Tongue

For the speedhacks just find which one is causing your game to crash, in fact using the search feature you may find a solution for those crashes. Usually speedhacks dont cause games to crash because of using too many but only 1 in particular.

That worked, thanks for the advice. Disabled IOPx2 and no crashes in about an hour of play, with no noticeable slowdown. Now I can enjoy Tales with proper voices and stable Pcsx2 Laugh

Thanks again.
Reply




Users browsing this thread: 1 Guest(s)