Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Team ICO games and different PCSX2 versions.
PCSX2 versions differences is a one big headache... -_-

I like Team ICO games. Yeah, ICO and Shadow of the Colossus (SOTC). ICO is unplayable for me on latest 1888 and previous beta version, didn't checked other beta's. "Hanging" at beginning of the game, when you walking on rounded stairs up to later dump down cage with Yorda. It looks like this: In some moment (in half high of stairs?) you cannot see that little boy and you can only moving by right analog controller (you got the current room view) and by left analog controller but only into right side - boy will be back down from stairs. He just cannot go higher in some moment. Sad SOTC runs fine. Both games have problems with shadows. In beta's, computer processor (core2duo) handling is better optimized, but something wrong is with graphic plugin.

So I taking back to stable release 0.9.6. ICO runs here without any "stairs problem" and smoothly but with 99% busy processor time. It's OK, I got still almost 60 fps and no sound glitches. But it's NOT OK for SOTC. Under stable version STOC is slooooow as hell and still have that irritating shadows. :/ DirectX? Latest version installed of course. Used and tested with both versions (9 and 10). All speed up and tweaks options was tested.

My hardware and software? Click on my nickname.

Maybe it's time to make dedicated optimalized PCSX2's versions for specific engines from specific developers? Most people play (or trying to) in FF series (Squaresoft), ICO i SOTC (Team ICO), GT series (Polyphony Digital). For rest of the games - leaving normal universal version.

Sponsored links

Search the forum for ICO, you need to go to config > advanced and set EE and VU to extra clamp.
SOTC is SLOW, you need to tweak your pc and set fast pcsx2 options.

Optimizing the emu for specific games? No thanks, we never did that, and we don't plan to start doing it now.
Shadow of the Colossus works at 60fps for me, you just need to tick all hacks on maximo, and play on native resolution.

If you really want to enjoy the game as the developers intended (of course, ignoring the ***** up shadow) you need to load up a savestate instead of using the "run cdrom" option.

what you should do is: Run the game for the first time, do a savestate anywhere. quit it. open the emu, and go to file > load > other and load your savegame. This is necessary cause GSdx automatically turns off the bloom, the fairy shader and the motion blur... doing this by bypass this block.
Hope it floats your boat.

Users browsing this thread: 1 Guest(s)