Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Texture Glitch on Fifa Street 2
#1
Hello everyone. I recently downloaded PCSX2 and Fifa Street 2, but when I played it the textures have been glitching (really weird textures everywhere). The game is still playable (and very fun) but I feel the game would be better with correct textures. Thank you for your help.

Computer specs:

8GB RAM
Intel Core i5 Processor
HD Readon 7850

PCSX2 specs:

[Image: Drb8g.png!]

[Image: J3sjf.png]

[Image: L6mCo.png]

[Image: 6UNqB.png]

Sponsored links

#2
(10-23-2012, 06:30 PM)Mysterymason Wrote: Hello everyone. I recently downloaded PCSX2 and Fifa Street 2.

This definitely sounds like you're saying you downloaded the game as well. Which in that case, no support is offered for pirated games.
We
Usually
Take
All
N*****
Garments
#3
It does? Damn. Anyway, the game doesn't matter. Is there anything wrong with my configuration that could cause problems?
#4
It does matter. I think this thread will be closed soon...
AMD Phenom II X4 975 BE OC 4.0 GHz, Corsair Hydro H70
AMD Radeon HD 6990 OC, Accelero Twin Turbo
ASUS Crosshair V Formula 990FX
OCZ Revodrive 3 X2 240 Gb
16 Gb G.Skill 1833 MHz

23 PS2's
#5
But it's a legit copy.. I think. I picked it up from a friend a few years ago and don't know it's origins. Any help would be appreciated.
#6
Okay, if it is original, it doesn't matter...
Try using DirectX11.
AMD Phenom II X4 975 BE OC 4.0 GHz, Corsair Hydro H70
AMD Radeon HD 6990 OC, Accelero Twin Turbo
ASUS Crosshair V Formula 990FX
OCZ Revodrive 3 X2 240 Gb
16 Gb G.Skill 1833 MHz

23 PS2's
#7
(10-23-2012, 07:18 PM)Mysterymason Wrote: But it's a legit copy.. I think. I picked it up from a friend a few years ago and don't know it's origins. Any help would be appreciated.

Ok fair enough then. Have you tried Software mode (F9)?
We
Usually
Take
All
N*****
Garments
#8
(10-23-2012, 07:23 PM)ps2freak Wrote: Okay, if it is original, it doesn't matter...
Try using DirectX11.

(10-23-2012, 07:26 PM)Rolento Wrote: Ok fair enough then. Have you tried Software mode (F9)?

Both don't work. I have fiddled around with loads of settings so it wouldn't be anything screamingly obvious (as chances are I've toggled that setting.)
#9
I'll check it out in a moment.. I just got Netflix !!
AMD Phenom II X4 975 BE OC 4.0 GHz, Corsair Hydro H70
AMD Radeon HD 6990 OC, Accelero Twin Turbo
ASUS Crosshair V Formula 990FX
OCZ Revodrive 3 X2 240 Gb
16 Gb G.Skill 1833 MHz

23 PS2's
#10
Ah, it's working now. It WAS the F9, thanks guys!!




Users browsing this thread: 1 Guest(s)