Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The Document of Metal Gear Solid 2 - Graphic problems
#1
Hello to everyone! First things first, my PC specs:

Quote:Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 4086 MB
CPU name = Intel® Core™ i5 CPU 750 @ 2.67GHz
Vendor/Model = GenuineIntel (stepping 05)
CPU speed = 2.666 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0098e3fd
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Now the problem: I am trying to run the THE DOCUMENT OF METAL GEAR SOLID 2 cutscenes properly. Sometimes they look great, but slowly as hell... The solution: the GSdx 0 (MSVC 16.00, SSE2) 0.1.16 [GSdx32-SSE2]. Rendered by OpenGL. 50/60 fps. But...

It's ugly!!! Look at that sawtooth!

[Image: vix8.jpg]

What's more:
Quote:3.x GL context successfully created
Failed to find glCopyImageSubData
Failed to find glClearTexImage
Failed to find glBindTextures
Failed to find glBufferStorage
Failed to find glGetTextureSamplerHandleARB
Failed to find glMakeTextureHandleResidentARB
Failed to find glMakeTextureHandleNonResidentARB
Failed to find glUniformHandleui64vARB
Failed to find glProgramUniformHandleui64vARB
Supported Opengl version: 3.3.11672 Core Profile/Debug Context on GPU: ATI Radeon HD 4600 Series. Vendor: ATI Technologies Inc.
Buggy driver detected, GL_ARB_separate_shader_objects will be disabled

INFO: GL_ARB_separate_shader_objects is not supported
INFO: GL_ARB_gpu_shader5 is not supported
INFO: GL_ARB_shader_image_load_store is not supported
INFO: GL_ARB_clear_texture is not supported
INFO: GL_ARB_buffer_storage is not supported
INFO: GL_ARB_shader_subroutine is not supported
INFO: GL_ARB_explicit_uniform_location is not supported
INFO: GL_ARB_multi_bind is not supported
INFO: GL_ARB_bindless_texture is not supported

Is there any way to fix this? Thanks!
Reply

Sponsored links

#2
Change the scaling to something higher than native(2x, 4x, etc)
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
OpenGL is work in progress, use the DirectX renderer. Probably greatly unhelped by the fact your GPU doesn't seem to support much of OpenGL 3.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
Native 2X + Direct3D is a good combination, but it causes FPS drops.

Another problem: cutscene freezes!

(http://www.youtube.com/watch?v=2d0dOCmvlVQ, 8:06 - Crashes for me at that moment)
Reply
#5
what version of PCSX2 are you using? do you get any errors in the log when it freezes?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
PCSX2 1.0.0.r5350, my friend!
Reply
#7
Try the very latest one from here:

http://buildbot.orphis.net/pcsx2/
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#8
ATI/AMD video drivers often have terrible support for OpenGL. Despite the crap that Nvidia has done to the Linux community, at least they do good support of OpenGL in their drivers.
But right in your log it says there's an issue with OpenGL due to 'buggy drivers' not supporting a specific feature. So as others have said, DirectX and 2X or Native Scaling.

You really shouldn't look to PS2 games for high-definition quality and graphics. Many of the 3D ones look very ugly by today's standards.
I play FF12 IZJS and it looks gorgeous, but that's cause I run it at 3X (with a few slowdowns if too much stuff goes on screen).
Reply
#9
Is there an option to turn the blur effects off? Thanks!!
Reply
#10
Config -> Video -> Plugin Settings

Enable HW Hacks

Click Configure.

Try skipdraw values 1 to whatever you feel like trying.

One might disable that effect.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply




Users browsing this thread: 1 Guest(s)