Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The Legend of Spyro Dawn of the Dragon resolution issue
#1
Im using the latest git revision of this emulator

EMU LOG

PCSX2 1.5.0-20160115002652 - compiled on Jan 15 2016
Savestate version: 0x9a0b0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Pro (build 10586), 64-bit
Physical RAM     =  16325 MB
CPU name         =  Intel® Core™ i7-4790K CPU @ 4.00GHz
Vendor/Model     =  GenuineIntel (stepping 03)
CPU speed        =  3.996 ghz (8 logical threads)
x86PType         =  Standard OEM
x86Flags         =  bfebfbff 7ffafbbf
x86EFlags        =  2c100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins...
Binding   GS: E:\CONSOLE GAMES\Ps2\THE LEGEND OF SPYRO DAWN OF THE DRAGON\plugins\GSdx32-AVX.dll 
Windows 10.0.10586
Binding  PAD: E:\CONSOLE GAMES\Ps2\THE LEGEND OF SPYRO DAWN OF THE DRAGON\plugins\LilyPad.dll 
Binding SPU2: E:\CONSOLE GAMES\Ps2\THE LEGEND OF SPYRO DAWN OF THE DRAGON\plugins\SPU2-X.dll 
Binding CDVD: E:\CONSOLE GAMES\Ps2\THE LEGEND OF SPYRO DAWN OF THE DRAGON\plugins\cdvdGigaherz.dll 
Binding  USB: E:\CONSOLE GAMES\Ps2\THE LEGEND OF SPYRO DAWN OF THE DRAGON\plugins\USBnull.dll 
Binding   FW: E:\CONSOLE GAMES\Ps2\THE LEGEND OF SPYRO DAWN OF THE DRAGON\plugins\FWnull.dll 
Binding DEV9: E:\CONSOLE GAMES\Ps2\THE LEGEND OF SPYRO DAWN OF THE DRAGON\plugins\DEV9null.dll 
Plugins loaded successfully.

HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 10.0.10586
Init PAD
(GameDB) 9693 games on record (loaded in 130ms)
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Current Renderer: OpenGL (Hardware mode)
Opening CDVD
isoFile open ok: E:\CONSOLE GAMES\Ps2\THE LEGEND OF SPYRO DAWN OF THE DRAGON\THE LEGEND OF SPYRO DAWN OF THE DRAGON.iso
Image type  = DVD
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (1306144 sectors)
Opening USB
Opening FW
Opening DEV9
3.x GL context successfully created
OpenGL information. GPU: GeForce GTX 980/PCIe/SSE2. Vendor: NVIDIA Corporation. Driver: NVIDIA 361.43
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_draw_buffers_blend is available
INFO: GL_ARB_separate_shader_objects is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_copy_image is available
INFO: GL_ARB_buffer_storage is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_clip_control is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available

McdSlot 0 [File]: E:\CONSOLE GAMES\Ps2\THE LEGEND OF SPYRO DAWN OF THE DRAGON\memcards\Mcd001.ps2
McdSlot 1 [File]: E:\CONSOLE GAMES\Ps2\THE LEGEND OF SPYRO DAWN OF THE DRAGON\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA     v01.60(07/02/2002)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.63, ctm:392Mhz, cpuclk:294Mhz detected)

PlayStation 2 ======== Hard reset boot
 ROMGEN=2002-0207, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
 <20020207-164243,ROMconf,PS20160AC20020207.bin:11552>
# Total accessable memory size: 32 MB (B:2:8:0) (363:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb  7 2002 16:41:20
  CPUID=2e20, BoardID=0, ROMGEN=2002-0207, 32M

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_218.20;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
found 0 symbols
ELF (cdrom0:\SLUS_218.20;1) Game CRC = 0xA0108EEE, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_218.20;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 © Sony Computer Entertainment Inc. 
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15) 
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLUS_218.20;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SLUS_218.20;1
0 00100000 00695680 ..........................................................................................................
Loaded, cdrom0:¥SLUS_218.20;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 © Sony Computer Entertainment Inc. 
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15) 
iop heap service (99/11/03)
loadmodule: fname cdrom0:¥IOP¥LIBSD.IRX args 0 arg 
loadmodule: id 25, ret 0
loadmodule: fname cdrom0:¥IOP¥SIO2MAN.IRX args 0 arg 
loadmodule: id 26, ret 0
loadmodule: fname cdrom0:¥IOP¥PADMAN.IRX args 0 arg 
loadmodule: id 27, ret 0
loadmodule: fname cdrom0:¥IOP¥MCMAN.IRX args 0 arg 
loadmodule: id 28, ret 2
loadmodule: fname cdrom0:¥IOP¥MCSERV.IRX args 0 arg 
loadmodule: id 29, ret 2
loadmodule: fname cdrom0:¥IOP¥RTFSSIOP.IRX args 2 arg 0
loadmodule: id 30, ret 0
loadmodule: fname cdrom0:¥IOP¥RWA.IRX args 0 arg 
IOP RwaRPCOpen
loadmodule: id 31, ret 2
Frame buffer size set to  512x512 (2048x2048)
Suspending single plugin: GS
Saving GS
Closing GS
Recovering single plugin: GS
Opening GS
Current Renderer: OpenGL (Hardware mode)
3.x GL context successfully created
OpenGL information. GPU: GeForce GTX 980/PCIe/SSE2. Vendor: NVIDIA Corporation. Driver: NVIDIA 361.43
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_draw_buffers_blend is available
INFO: GL_ARB_separate_shader_objects is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_copy_image is available
INFO: GL_ARB_buffer_storage is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_clip_control is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available

Loading GS
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(GameDB) Unloading...


Iv tried default settings and iv messed around with alot of them too, using Opengl Hardware as that seems the best for most the games
Iv tried all Crc hacks and all Blending options too, its 100% seems related to the internal resolution

This issue happens when i use any resolution higher than Native

Native
[Image: slNCE5T.jpg]
Any Resoulution higher than Native
[Image: AH1aht7.jpg]


Thanks for the Hard work you guys do, most my games look much better than on my Ps2, hope you can please sort resolution with this game
PC SPECS - MSI GTX 980 GAMING 4G, I7 4790K @ 4GHZ, 16GB RAM, WINDOWS 10 PRO 64BIT

GAME DOCK ICONS MADE BY ME - http://30011887.deviantart.com/gallery/
Reply

Sponsored links

#2
Upscaling is a hack and a lot of post processing effects break when you raise that value, so this is likely to happen, you could probably put the crc hack level up to turn some of the post processing off which should make it look better.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
I'm not even sure what's the issue... please always mention the expected result and the current (wrong result). (I haven't played the game so I wouldn't know the expected output)

posting a comparison screenshot compared to native and higher resolutions would be nice. please also provide your emulog so that we can confirm that you're using the official certified plugins / version of the emulator.
Reply
#4
@refraction, ah ok thanks for info, i tried crc hacks but all resulted the same output

@ssakash, iv edited my first post with Native (looks worse when playing the game fullscreen as game is blurry and jagged)
Expected result would be to not have green lines across screen, i also put my emu log in first post
PC SPECS - MSI GTX 980 GAMING 4G, I7 4790K @ 4GHZ, 16GB RAM, WINDOWS 10 PRO 64BIT

GAME DOCK ICONS MADE BY ME - http://30011887.deviantart.com/gallery/
Reply
#5
Set the skipdraw hack to 1 to remove that bad effect. (Config -> Video (GS) -> Plugin Settings... -> check the "Enable HW Hacks" box -> click the "Configure Hacks" button -> set the Skipdraw box to 1.)

Another option that sort of fixes that bad effect is setting the Round Sprite hack to either "Half" or "Full", whatever that effect is is affected by that hack and ends up much less broken but is still not correct versus native resolution, the effect ends up somewhat like a slight mosaic filter over some things like fire effects.

Also worth noting, the game is playable with minimal graphical issues (that I can tell) with the CRC hack level set to Minimum (Debug) with either the Skipdraw hack set to 1 or the Round Sprite hack set to "Half" or "Full". (This is with the OpenGL backend, of course, not sure how D3D11 or D3D9 handle it anymore since OpenGL has gotten so good.)
Reply
#6
@Karashata, omg i actually forgot about that setting in there, Skipdraw 1 makes my game brighter, i settled for Round Sprite to Full, seems the issue is gone and everything looks fine again at 4x internal resolution

Thanks so much Smile

Yeah i find that OpenGL is the best by far, less glitches and better speed in most games
PC SPECS - MSI GTX 980 GAMING 4G, I7 4790K @ 4GHZ, 16GB RAM, WINDOWS 10 PRO 64BIT

GAME DOCK ICONS MADE BY ME - http://30011887.deviantart.com/gallery/
Reply
#7
That was something that bugged me for a while when I started playing the game with PCSX2, but the issues with that particular layer were a lot worse, a lot of coloured noise over most of the screen. Gregory's done a lot of work on the GSdx plugin which mostly fixed it (did fix it at native resolution) but it's clearly something that's not really meant to be upscaled. I'm surprised it comes out as well as it does with the Round Sprite hack enabled, I have no idea what possessed me to try playing with that hack but whatever it was was on to something, I guess.

Either way, glad to have helped!
Reply
#8
Yeah he has done a great job, iv used this emu over the past 5/6 years now, for me this emu is saving my ps2 disks in a way, at the moment they have gotten very scratched, i know one day they prob wouldnt work so by making iso's etc they will never get old and now they are backed up on bluray disks Smile

Thanks again Laugh
PC SPECS - MSI GTX 980 GAMING 4G, I7 4790K @ 4GHZ, 16GB RAM, WINDOWS 10 PRO 64BIT

GAME DOCK ICONS MADE BY ME - http://30011887.deviantart.com/gallery/
Reply




Users browsing this thread: 1 Guest(s)