Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The shadow in Valkyrie Profile 2
#1
I noticed that when I was using the softrender renderer in Valkyie Profile 2, there is the shadow under the character in towns and dungeuns. But after I switched to hardware renderer, no matter how I configure the settings, the shadow cannot appear. Is there anyone know how to display the shadow in the hardware renderer mode?

My settings and the software renderer screenshoots are uploaded.


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
If you use OpenGL With blending accuracy set to high (i think) you will have shadows in hardware mode. It might be Ultra blending accuracy, so don't quote me Tongue Have a play with that setting.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Yeah, even if I set the the bending unit to ultra, it's still no shadows. Thanks for refractoin's reply.
Reply
#4
This is a CRC hack. You can disable them in GSdx but you will not like the resulting framerate Wink
Reply
#5
(05-28-2017, 01:01 AM)rama Wrote: This is a CRC hack. You can disable them in GSdx but you will not like the resulting framerate Wink

Oh, it seems you're right. However, even if I disabled the CRC hack, showdows are shown on the screen, I also can see some strange projection lines above the shadow. I have been waiting for fixing this error for years. Perhaps it will never been fixed.
Reply
#6
The glitch might be from upscaling.
Reply
#7
Yes. The framebuffer alpha channel is used as a stencil buffer (a counter by pixel used as a mask). Upscaling will interpolate the value which is wrong.

If we can avoid some GSdx internal rescaling operations, it will look better. And it might be a bit faster.
Reply
#8
Wouldn't we have to upscale the framebuffer eventually? Maybe it's possible to do the mask before it though.
Reply
#9
The issue is that frame buffer read back (when frame buffer is used as input texture) is rescaled. Which is bad. Correct solution should be to rescale the GS texture coordinate instead.
Reply
#10
I'm surprised that I understand a little bit what you are talking about.
Reply




Users browsing this thread: 1 Guest(s)