Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread creation error. I'm stumped... HELP.
#1
Code:
PCSX2 1.4.0-20160105132032- compiled on Jan  5 2016
Savestate version: 0x9a0b0000

Host Machine Init:
    Operating System =  Microsoft Windows 10 Pro (build 14393), 64-bit
    Physical RAM     =  8141 MB
    CPU name         =  Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz
    Vendor/Model     =  GenuineIntel (stepping 03)
    CPU speed        =  3.190 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7ffafbff
    x86EFlags        =  2c100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: E:\PCSX2_1.4.0\Plugins\gsdx32-avx.dll
Windows 10.0.14393
    Binding  PAD: E:\PCSX2_1.4.0\Plugins\padPokopom.dll
    Binding SPU2: E:\PCSX2_1.4.0\Plugins\spu2-x.dll
    Binding CDVD: E:\PCSX2_1.4.0\Plugins\cdvdiso.dll
    Binding  USB: E:\PCSX2_1.4.0\Plugins\USBnull.dll
    Binding   FW: E:\PCSX2_1.4.0\Plugins\FWnull.dll
    Binding DEV9: E:\PCSX2_1.4.0\Plugins\DEV9null.dll
Plugins loaded successfully.

HLE Notice: ELF does not have a path.

Initializing plugins...
    Init GS
Windows 10.0.14393
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
(GameDB) 9693 games on record (loaded in 165ms)
Shutting down plugins...
Plugins shutdown successfully.
(pxActionEvent) Thread creation error: MTGS thread never posted startup semaphore.(thread:EE Core)
(GameDB) Unloading...

Okay, so I am completely stumped. See my computer specs above.  I also have an EVGA Nvidia GTX 960 2gb card.

Background info:
  • Added ps2 isos to Steam using Ice
  • I stream my games to my TV using Gamestream (which in turn, uses Steam Big Picture Mode)
Now, I only get the above error when I try and stream.  I'll click "Play" in Steam, it'll flicker a bit, then close back out to Steam after a few seconds.  I've even tried to add the actual emulator as a non-steam game.  When I run it, I get the console... but if I try and click on ANYTHING, PCSX2 freezes and I have to close it.
What's wrinkling my brain is the fact that if I stream through launchbox, it seems to work okay.  Or if I run PCSX2 physically on my computer (not streaming), everything works perfectly.

What I've tried
  1. Uninstalling and reinstalling PCSX2
  2. Troubleshooting the GS Plugin
  3. Googling "semaphore"
  4. Freaking out
If anyone can point me in the right direction, I would be ecstatic.

Bonus: What does ELF does not have a path mean?
I don't think it messes anything up, but I'm curious.  In my time ripping ps2 isos and modding the consoles, I remember something about elf files...


Attached Files
.txt   emuLog_BAD.txt (Size: 1,47 KB / Downloads: 20)
Reply

Sponsored links

#2
When you said physically on your computer (not streaming) are you still launching through Steam the same way as if you were? ie Are you using Steam at all in the process? If you are did you put Steam into Big Picture Mode locally and launched PCSX2 through it?
Reply
#3
(04-25-2017, 07:27 AM)TkSilver Wrote: When you said physically on your computer (not streaming) are you still launching through Steam the same way as if you were?  ie Are you using Steam at all in the process?  If you are did you put Steam into Big Picture Mode locally and launched PCSX2 through it?

Yes.
Yes.
Yes.
If I am sitting at my computer, I can run PCSX2 Through Steam, Steam Big Picture Mode, or by itself and everything runs perfectly fine.  Here is a log of that:

Code:
PCSX2 1.4.0-20160105132032- compiled on Jan  5 2016
Savestate version: 0x9a0b0000

Host Machine Init:
    Operating System =  Microsoft Windows 10 Pro (build 14393), 64-bit
    Physical RAM     =  8141 MB
    CPU name         =  Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz
    Vendor/Model     =  GenuineIntel (stepping 03)
    CPU speed        =  3.190 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7ffafbff
    x86EFlags        =  2c100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: E:\PCSX2_1.4.0\Plugins\gsdx32-sse2.dll
Windows 10.0.14393
    Binding  PAD: E:\PCSX2_1.4.0\Plugins\padPokopom.dll
    Binding SPU2: E:\PCSX2_1.4.0\Plugins\spu2-x.dll
    Binding CDVD: E:\PCSX2_1.4.0\Plugins\cdvdiso.dll
    Binding  USB: E:\PCSX2_1.4.0\Plugins\USBnull.dll
(GameDB) 9693 games on record (loaded in 140ms)
    Binding   FW: E:\PCSX2_1.4.0\Plugins\FWnull.dll
    Binding DEV9: E:\PCSX2_1.4.0\Plugins\DEV9null.dll
Plugins loaded successfully.

HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 10.0.14393
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: V:\JakandDaxter.iso
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (713152 sectors)
    Opening USB
    Opening FW
    Opening DEV9
Current Renderer: Direct3D9 (Hardware mode)
NVIDIA GeForce GTX 960 (22.21.13.8165)
McdSlot 0 [File]: C:\Users\King Kong DruHill\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\King Kong DruHill\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v02.00(14/06/2004)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.70, ctm:392Mhz, cpuclk:294Mhz detected)

PlayStation 2 ======== Hard reset boot
ROMGEN=2004-0614, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
<20040614-100909,ROMconf,PS20200AC20040614.bin:11696>
# Total accessable memory size: 32 MB (B:2:8:0) (370:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb  6 2003 08:38:48
 CPUID=2e20, BoardID=0, ROMGEN=2004-0614, 32M


IOP Realtime Kernel Ver.0.9.1
   Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname rom0:OSDSYS secname all
loadelf version 3.30
Input ELF format filename = rom0:OSDSYS
0 00100000 000586dc ......
Loaded, rom0:OSDSYS
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..
ROM directory not found

PlayStation 2 ======== Update reboot complete
cdvdman Init
rmreset start
rmreset end
clearspu: completed
Pad Driver for OSD (2000/12/05 18:05) 392, 128

IOP Realtime Kernel Ver.0.9.1
   Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
read/write allocate memory 4000
open name rom0:OSDVER flag 1 data 4a978
open fd = 2
open name rom0:ROMVER flag 1 data 4a978
open fd = 2
open name rom0:XDEV9 flag 1 data 4a978
open fd = 2
loadmodule: fname rom0:XDEV9 args 0 arg
dev9: unknown dev9 hardware.
loadmodule: id 32, ret 1
loadmodule: fname rom0:XDEV9SERV args 0 arg
loadmodule: id -200, ret 1
open name rom0:FONTM flag 1 data 4a978
open fd = 2
open name rom0:FNTIMAGE flag 1 data 4a978
open fd = 2
open name rom0:SNDIMAGE flag 1 data 4a978
open fd = 2
open name rom0:TEXIMAGE flag 1 data 4a978
open fd = 2
open name rom0:ICOIMAGE flag 1 data 4a978
open fd = 2
open name rom0:TZLIST flag 1 data 4a978
open fd = 2
_spu_rev_offsetaddr 1f9021
### addr = 1034255  size = 28640
_spu_rev_offsetaddr 1d9021
### addr = 968719  size = 28640
open name rom0:ROMVER flag 1 data 4a978
open fd = 2
get val add 3c0 type 2 ret 1ff000
get val add 1ff000 type 2 ret 0
open name rom0:PS1ID flag 1 data 4a978
open fd = 2
open name rom0:PS1VERA flag 1 data 4a978
open fd = 2
open name rom1:DVDID flag 1 data 4a978
open fd = -6
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
    Closing PAD
    Closing GS
Plugins closed successfully.
Decommitting host memory for virtual systems...
EE/iR5900-32 Recompiler Reset
Shutting down plugins...
Plugins shutdown successfully.
(GameDB) Unloading...

As you can see, the thing fires up right away and there are no issues.
Reply
#4
Apparently... it was the Popcorn Xinput plugin. Changed to LilyPad and Viola. Wow.
Reply




Users browsing this thread: 1 Guest(s)