Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Timesplitters: Future Perfect... ALMOST works OK, any suggestions?
#1
So Timesplitters Future Perfect does work, and I can get it to run at a reasonable speed, but there is a sort of static effect on the bottom half of the screen when you start a level, and also when certain weapons are fired and during other special effects. I've tried various options like enabling/disabling 8 bit textures, frame skipping, all kinds of stuff which people used to fix OTHER problems, but none of these help with my problem.

I've searched the forums and watched some youtube videos and this seems to be a common problem - "game works fine except for some graphical artifacts on bottom half of the screen". It seems that if you are playing a deathmatch you get it just for a second or two and during explosions, but in singleplayer campaign it is more of a problem and spoils enjoyment, such that I might as well just play the game on my old PS2 then bother emulating it.

I've tried both the normal released version of PCSX2 and also the latest experimental build. (By the way, MTVU definately does not help, makes game unplayably slow, took half a minute to load up menu screens.)

Anyway, I'm thinking the graphical glitch it might have something to do with post processing. I know that some games have had their post processing disabled to avoid graphical artifacts - apparently Metal Gear Solid 3 looks a total mess with post processing so it is disabled by default.

Anyone know how I might disable post processing in Timesplitters Future Perfect? And has anyone tried it, did it fix that issue? Did it cause any other problems?

(Software mode isn't an option, as it is a graphics card intensive game. I have a Quad Core Q9550 2.8ghz and a 560GTI-TX, 2GB version, at 880Mhz, and 8GB of RAM, Vista 64.)

Sponsored links

#2
If you can get that Q9550 to at least 3.6GHz which it almost will do (mine was a good E0 that did 4GHz at stock VTT and near stock Vcore), any stepping on stock cooler, you will see much better SW mode performance and probably MTVU performance as well, will SW be playable i don't know as i have the 8 threaded i7 920 @ 4GHz and don't have that game.

Have you tried changing clamping modes etc for EE/IOP and VUs? Full and Extra + Preservative sign? Tried native res and 2x native res? Using Direct X 11 right? Just post PCSX2 settings..
-Core i7 6700k @ 4.5 GHz
-GIGABYTE Z170X-Gaming 5
-G.SKILL Ripjaws V 16GB DDR4 2400 @ 14-13-13-30-1T
-EVGA GTX 970 4GB @ 1380/1853 MHz
-Crucial MX100 512GB, Silicon Power S60 120GB, Toshiba 2TB 7200 RPM
-PC P & C Silencer 750 Quad
-Windows 7 x64

-----

-Core i7 4710MQ
-16GB DDR3 1866
-GTX 965M 4GB @ 1127/1353 MHz
-Mushkin ECO2 240GB, HGST 1TB 7200 RPM
-Windows 7 x64
#3
Graphics card extensive does not mean it will not run well in software mode, in fact software mode might give you better results depending on your cpu. A good example of this is Viewtiful Joe, slow in hardware mode but full speed in software mode(from what I've read anyway, as both modes run full speed for me, I just prefer software mode).
#4
I found that Timesplitters: Future Perfect ran about half normal speed in software mode, with everyone talking like they are in bullet time; I doubt that overclocking my processor would get that to 100%. Also there are a few little visual artifacts in software mode too. So running in hardware mode would be ideal, if not for this one damn problem of a wall of static appearing on the bottom half of the screen in various circumstances.

Been messing with the clamping modes - no change. Tried the alpha hack, no change, tried some skipdraw settings, made it worse. I had hoped to use an emulator to do a "Let's Play" walkthrough of the game, but I guess I'd be better of using my actual console than trying to emulate it.
#5
But software mode did fix your issue, right?
#6
Indeed software mode did get rid of the static filling half the screen. Instead I got other visual artifacts though, and they are continuous rather than in just certain situations. SOme sort of semi-visible square blocks moving around the landscape. I think maybe something to do with fog effects that are used in many of the levels? Or some other post processing effect, I'm not sure. In any case, it means that even if I could run software mode at full speed, it wouldn't be a good replacement for hardware mode, I'd be trading one visual problem for another.

All the other threads that mention this game on these forums seem to have the same issue. I had hoped that maybe one of the more recent updates had added some new feature that meant there was a workaround, but I guess not. Sad

I guess nobody hsa ever been that concerned because the static effect isn't continuous, it's only at the start of a level and when certain explosive weapons are used. Fine for just playing through the game. But since I wanted to record a high quality walkthrough of the game, it's not really suitable.
#7
(01-11-2012, 01:23 PM)your evil twin Wrote: I doubt that overclocking my processor would get that to 100%.

Yeah. I doubt that overclocking would give any benefit at all. Rolleyes
#8
The software problem could probably be fixed by using a different clamp or round mode.
#9
Hi guys i've also been having problems with my Timesplitters future perfect.. i'm a noob when it comes to going through the settings for the pcsx2, however pad/sound etc are perfect and the game runs at a fairly decent FPS my main concern is that the graphics can completely go off scale, for example i have a screenshot i took when i turned to face a certain angle, a portion of my screen turned to this:

http://img405.imageshack.us/img405/6602/73759642.png

and then was stuck like it.. any suggestions/cures/anything? Tongue

cheers
#10
only solution for that problem at the moment is using software mode in GSdx (F9 while playing) which will make it slow...
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64




Users browsing this thread: 1 Guest(s)