Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Timestretch audio mode and pal games forced 60 hz
#1
So there's a way to get audio sync correctly with pal games forced to go at 60 fps ? I'm trying silent hill 4 the room pal and with time stretch audio mode i get delay with audio in cut scene in real time, with async mix, audio is in sync but i have crackling audio, but i have latency value stock at 150. There's a easy solution to solve this ? The problem is the latency with async mix ?
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Why do you want to run a pal game at 60hz? How do you achieve that?
Reply
#4
forcing a game at 60fps that is meant for the PAL region will make it run faster, which will cause time stretching to speed the audio up, which could cause inaccuracies. you can probably lower it by making the buffer smaller in the timestretch configuration.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
(09-30-2015, 11:30 AM)refraction Wrote: forcing a game at 60fps that is meant for the PAL region will make it run faster, which will cause time stretching to speed the audio up, which could cause inaccuracies.  you can probably lower it by making the buffer smaller in the timestretch configuration.

The time stretcher can use bigger buffers for smoother speed transitions and less crackling - and more lag, or smaller buffer for less lag but more crackling and less fun speed transitions (in case the game speed fluctuate because the system is not fast enough to keep running it at a fixed 100% speed).

In general, use the smallest buffer which doesn't have cracklings on a specific system for a specific game, or use slightly bigger buffer which will work for more games on a specific system without crackling, but will also have slightly bigger lag.

Also, I'm not sure if the best way to speedup PAL games (and to play them faster than they would on an actual PS2) is to set the PAL speed to 60 (or 59.94) Hz. A better way would probably be to set the "turbo" speed to 120% and just play in turbo mode.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#6
ok so i tried the turbo at 120% but this solution is good for certain games, for silent hill 4 seems ok, but it's not for every game, example, shadow of memories has ton of talking, and with turbo mode, the voice is accelerated, not so much, but it's "tedious" to listen these voices for all the duration of the game. I should try lowering the timestretch values, let's see what happen!

willkuer it's easy, just change the values in the PCSX2_vm.ini file

jesalvein it's not something related to specs or pcsx2 build. Thanks anyway^^
Reply
#7
Just tried with all values at the mininum and there's a little less delay but it's not enough! Sad
Reply
#8
(09-30-2015, 02:41 PM)avih Wrote: Also, I'm not sure if the best way to speedup PAL games (and to play them faster than they would on an actual PS2) is to set the PAL speed to 60 (or 59.94) Hz. 

That's what I did when I tried the PAL version of FFX, and also when I play KH2 at 120fps (forcing the NTSC framerate to 119.88fps in this case). The audio works correctly that way.
CPU: Intel Core i7 7700k @ 5GHz
GPU: Gainward GTX 1080 GLH
Motherboard: Gigabyte Aorus GA-Z270X-Gaming 5
RAM: G.Skill Trident Z RGB DDR4 3866MHz 16GB CL18
Monitor: Dell S2716DG
OS: Windows 10
Reply
#9
(09-30-2015, 07:03 PM)luke76bg Wrote: ok so i tried the turbo at 120% but this solution is good for certain games, for silent hill 4 seems ok, but it's not for every game, example, shadow of memories has ton of talking, and with turbo mode, the voice is accelerated, not so much, but it's "tedious" to listen these voices for all the duration of the game. I should try lowering the timestretch values, let's see what happen!

willkuer it's easy, just change the values in the PCSX2_vm.ini file

I know how one can achieve to run a game at 60Hz that is designed to run at 50Hz. Other people are actually patching their isos to achieve something like that.

I just have the feeling you don't know what the change of settings you did includes.

You increase the speed of the game over normal and are still wondering why dialogs are accelerated? What would you expect?

Or maybe more general: What kind of problem do you want to solve that you try to solve by setting the pal framerate to 60 Hz? And why 60Hz and not 55Hz, 70Hz or 200Hz?
Reply




Users browsing this thread: 1 Guest(s)