Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tweaking for some FPS gain
#1
Heya,

I've been playing Persona 4 fairly OK on the 0.9.8 version of the PCSX2 emulator but sometimes the FPS seems to dip down below 30 and I encounter slowdown.

I've tried FFX as well and the cinematics work great and such but there's slowdown here and there as well.

I do suspect I could use some tweaking to improve this and I don't expect it to run flawless, as close as possible will do really, seeing as both are turn-based games slow down won't affect gameplay all to much.

Anyways, here are my specs:

From CPU-Z

Processor 1 ID = 0
Number of cores 4 (max 8)
Number of threads 8 (max 16)
Name Intel Core i7 2720QM
Codename Sandy Bridge
Specification Intel® Core™ i7-2720QM CPU @ 2.20GHz
Package (platform ID) Socket 988B rPGA (0x4)
CPUID 6.A.7
Extended CPUID 6.2A
Core Stepping D2
Technology 32 nm
TDP Limit 45 Watts
Core Speed 798.2 MHz
Multiplier x FSB 8.0 x 99.8 MHz
Stock frequency 2200 MHz
Instructions sets MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, EM64T, VT-x, AES, AVX
L1 Data cache 4 x 32 KBytes, 8-way set associative, 64-byte line size
L1 Instruction cache 4 x 32 KBytes, 8-way set associative, 64-byte line size
L2 cache 4 x 256 KBytes, 8-way set associative, 64-byte line size
L3 cache 6 MBytes, 12-way set associative, 64-byte line size
FID/VID Control yes


Turbo Mode supported, enabled
Max non-turbo ratio 22x
Max turbo ratio 33x
Max efficiency ratio 8x
Max Power 60 Watts
Min Power 40 Watts
O/C bins none

GPU: Nvidia NVS 4200M
GPU-z link: http://gpuz.techpowerup.com/12/05/05/8ky.png

The machine is running on 8 gigs of ram with W7 enterprise x64 edition if it's of any help / need.

Emulator settings: http://imgur.com/e1w0J

Any help is well appreciated!

B.R
Waffle
Reply

Sponsored links

#2
**i not sure if that nvidia card is holded up to the limit.
**is your laptop is at battery mode and/or your power plan is at "Power Saver" that another symptoms of slowdowns
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
Tried setting the windows power plan to maximum performance? Also give the latest SVN a try: http://pcsx2.net/svn.php
and enable the new MTVU speed hack hack
[Image: newsig.jpg]
Reply
#4
I'm running it in every max-performance setting possible in terms of "power settings" and always with charger attached, the battery usage is quite intense with the emulator running.

I had to do some tweaking with the GS settings of PCSX2 from start because I had some glitchy graphics and terrible FPS, what I'm after is to see if there's any way to tweak the settings even better than I've done or if what I've set now is the best I can hope for on this machine.

Also, is it still true that in terms of intel vs amd, intel cpu's are still preferred in terms of emulation?

I'll definately give the latest SVN a try as well! thanks.
Reply
#5
It's not a point of preferred really, it's that intel's processors always have greater IPC than their AMD counterparts.
[Image: newsig.jpg]
Reply
#6
Was thinking preferred as in better, but I get your point.

Anyways if there's any other room for tweaking with settings other than already posted feel free to let me know, thanks for the info so far.
Reply
#7
You might want to check your processes when fps drop happens.
If there's anything that overloads your CPU(well exept the emulator itself) just delete the process and ofcourse if it not belongs to Windows. Then switch back to emulator to check current fps.
e5200 2x3.33Ghz || en9600gt 512Mb ddr3 OC'd 256bit || 4x1Gb ddr2 || || 80Gb 160Gb 1Tb 7200rpm || Win7 x64
Reply
#8
(05-05-2012, 06:14 PM)index Wrote: just delete the process and ofcourse if it not belongs to Windows

I certainly not recommending this, it would be better of you do some google first before assuming it was something bad or not belonging to Windows...Smile
Reply
#9
(05-05-2012, 09:56 PM)kohaku2421 Wrote: I certainly not recommending this, it would be better of you do some google first before assuming it was something bad or not belonging to Windows...Smile

I know my way around Windows well enough to know what to shut down and what to leave be, but thanks for the warning tho Smile

Shutting down anything running in the background such as browsers etc does improve it slightly, but since the lag is usualy greater the more objects there are on screen I simply suspect either the machine being not powerful enough or simply badly configured settings in the emulators GS by me.
Reply
#10
In some games, such as Persona 4, having EE and VU speedhacks enabled can cause massive slowdown in battle scenes. So your first step should be to put both sliders to the left, but leave the other hacks enabled. Especially MTVU.

You could also try running in Direct X 10/11 mode in Gsdx, and turning on "use native resolution".
Reply




Users browsing this thread: 1 Guest(s)