Thread Rating:
  • 17 Vote(s) - 3.82 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TwinPad v0.9.1
A fix release is up. See OP for details.

Sorry for the double post.
Reply
Running WinXP SP3 on an arcade cabinet. Updated working TwinPad 0.8.3 to non-working 0.9.1. Always get the error-message when loading a game

D:/Wxwidgets/include/wx/arrstr.h(178): asset nIndex < m_nCount" failed in wxArrayString::Item(): wxArrayString: index out of bounds [in thread de4]
Call stack
[00] 004BE31B
[01] 004BE01B
[02] 0047BE80
[03] A164F8E4

Do you want to stop the program?
You can also choose Cancel to suppress further warnings.

What to do??
Reply
(05-03-2015, 10:12 AM)ClarkKent Wrote: Running WinXP SP3 on an arcade cabinet. Updated working TwinPad 0.8.3 to non-working 0.9.1. Always get the error-message when loading a game

D:/Wxwidgets/include/wx/arrstr.h(178): asset nIndex < m_nCount" failed in wxArrayString::Item(): wxArrayString: index out of bounds [in thread de4]
Call stack
[00] 004BE31B
[01] 004BE01B
[02] 0047BE80
[03] A164F8E4

Do you want to stop the program?
You can also choose Cancel to suppress further warnings.

What to do??

If you mean this:
   

Yup, that means you did not configure the plugin at all and you started using the new TwinPad v0.9.1 with the old configurations.

For now please re-"configure" the plugin. And the issue will be gone.

Next update, I will make sure you can't start emulation when using old settings. Biggrin

Note: You can delete TwinPad.exe, TwinPad.ini and TwinPad_COMBOs.ini files from the old version to be sure that you start on a clean
slate.

TwinPad doesn't need EXE file anymore and doesn't use it at all.
Reply
Thank you - this was it! Smile Never thought the old ini could be a problem. Now after deleting everything from the old version and configuring all new (by the way - the ALT key can be used now! Great!), the plugin works as expected! I'm also really happy that the test message from the old version is also not there anymore! Smile

Thank you very very much for the new version! Now my PCSX2 installation is fully complete! Smile
Reply
Hello,

i am currently using v0.9.1 for lulu's fury. I set everything to delay 1, like your picture in post one.
But I only manage until 8 or 9. Do I did something wrong?
This is what I did...
[Image: Capture2_zpsbjxfnqgw.jpg]
Reply




Users browsing this thread: 1 Guest(s)