Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(Ubuntu 15.10 64bit) Missing :i386 dependencies libglib2 and libgtk2
#1
Hey guys whenever I try to install pcsx2, I get alarmed about missing dependencies.
The missing dependencies are as following:
  • libgdk-pixbuf2.0-0:i386
  • libglib2.0-0:i386
  • libgtk2.0-0:i386
  • libwxgtk3.0-0v5:i386
It seems to be a 32-bit program related issue as 64-bit programs like Dolphin and Retroarch work but :i386 ones like Wine don't. But Steam works.
I don't really know what to do, I thought maybe some headers are missing somewhere? I can't get to install libglib2.0-0:i386 and libgtk2.0-0:i386, thought the 64-bit versions seem to be installed. Is there a specific way to activate compatibility with 32-bit programs in Ubuntu?

I enabled 32-bit architecture before installation "sudo dpkg --add-architecture i386" and system is up to date.

I would be greatful if some of you could help me out.
You can't find a detailed report including the terminal output on stackexchange: https://askubuntu.com/questions/733421/u...nd-libgtk2

Thank you!
Reply

Sponsored links

#2
Quote: can't get to install libglib2.0-0:i386 and libgtk2.0-0:i386
It is bad.

Quote:> dpkg -l libglib2.0-0
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-======================================================-================================-================================-=================================================================================================================
ii libglib2.0-0:amd64 2.42.1-3 amd64 GLib library of C routines
ii libglib2.0-0:i386 2.42.1-3 i386 GLib library of C routines
You must have both installed. Only 32 bits will be used by PCSX2 but 64 bits will be used by the remaining of the OS.

Try to apt-get update, and apt-get upgrade your system.

Could you post me the output of those 2 commands
apt-cache policy libglib2.0-0:amd64 libglib2.0-0:i386
apt-get install libglib2.0-0:amd64 libglib2.0-0:i386
Reply
#3
(02-14-2016, 02:29 PM)gregory Wrote: It is bad.

You must have both installed. Only 32 bits will be used by PCSX2 but 64 bits will be used by the remaining of the OS.

Try to apt-get update, and apt-get upgrade your system.

Could you post me the output of those 2 commands
apt-cache policy libglib2.0-0:amd64 libglib2.0-0:i386
apt-get install libglib2.0-0:amd64 libglib2.0-0:i386

"apt-get update and apt-get upgrade" , I have already tried those. Everything 'appears' to be up to date.

I get the following output for the 2 commands:
Code:
apt-cache policy libglib2.0-0:amd64 libglib2.0-0:i386
libglib2.0-0:
 Installed: 2.46.2-1ubuntu1
 Candidate: 2.46.2-1ubuntu1
 Version table:
*** 2.46.2-1ubuntu1 0
       100 /var/lib/dpkg/status
    2.46.1-1 0
       500 http://archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
libglib2.0-0:i386:
 Installed: (none)
 Candidate: 2.46.1-1
 Version table:
    2.46.1-1 0
       500 http://archive.ubuntu.com/ubuntu/ wily/main i386 Packages

Code:
sudo apt-get install libglib2.0-0:amd64 libglib2.0-0:i386
Reading package lists... Done
Building dependency tree      
Reading state information... Done
libglib2.0-0 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.46.2-1ubuntu1) but 2.46.1-1 is to be installed
libglib2.0-0:i386 : Breaks: libglib2.0-0 (!= 2.46.1-1) but 2.46.2-1ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.
Reply
#4
Where did you get your glib version? The version doesn't come from ubuntu (2.46.1 vs 2.46.2)
Reply
#5
(02-14-2016, 05:26 PM)gregory Wrote: Where did you get your glib version? The version doesn't come from ubuntu (2.46.1 vs 2.46.2)

I don't know, I never installed libglib. May be another program installed it? Is there a way to switch to the correct Ubuntu version?
Reply
#6
[Image: hnf1TDJ.png]

Package, force version?



This would remove gnome, unity, ubuntu settings, ubuntu desktop, ubuntu sso, etc..

If I do this. I have to reinstall the removed things after restart via right crtl+alt+f1 then again right?
Would something like apt-get install ubuntu-desktop restore the missing things, minus gnome?
or does this completely break ubuntu?
Reply
#7
Normally it mustn't remove anything. Except if you're gnome depends on it.

apt-get install libglib2.0-0=2.46.1-1
Reply
#8
Can you print the content of /etc/apt/source* (main file and file in the .d directory)
Reply
#9
I think I made a horrible mistake before I read your reply. I forced the libglib version in synaptic. When I rebooted I installed ubuntu-desktop and gnome again. But there isn't any gui after rebooting. I reinstalled and reconfigured gdm but there still is no gui. (the irony of the situation: i managed to install pcsx2 via command line)
Reply
#10
By gui, you mean the x server? Dis you install back unity?
Reply




Users browsing this thread: 1 Guest(s)