Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu/Mint: Black screen with discrete GPU
#1
Hi there,
I have just upgraded to Linux Mint 18 / Ubuntu 16.04 and decided to install PS2 emulator. When using the integrated GPU (Intel HD Graphics 4000), it works, but I naturally get very low FPS, hence I tried to let the emulator use the dedicated GPU (AMD HD8750M). To make the program use the discrete GPU, I run it with PRIME command:

Code:
DRI_PRIME=1 PCSX2

As long I run games with the integrated GPU, it kind of works, however, as soon as I try to run games on the discrete GPU, the only thing I get is a black screen, while the sound is present. Don't know, if there is any relation to this, but the same happens in PCSX Reloaded.

I appreciate any help. :-)
Thanks.
J. K.
Reply

Sponsored links

#2
Could you post the part of the log that show the detection of the openGL status
Reply
#3
Sure. I tried both SW and HW modes and they both gave the exact same output. Here is the log:
Code:
    Opening GS
Current Renderer: OpenGL (Hardware mode)
glX-Version 1.4 with Direct Rendering
OpenGL information. GPU: Gallium 0.4 on AMD OLAND (DRM 2.43.0, LLVM 3.8.0). Vendor: X.Org. Driver: (Core Profile) Mesa 11.2.0
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_draw_buffers_blend is available
INFO: GL_ARB_separate_shader_objects is NOT SUPPORTED
INFO: GL_ARB_shader_image_load_store is NOT SUPPORTED
INFO: GL_ARB_copy_image is available
INFO: GL_ARB_buffer_storage is available
INFO: GL_ARB_clear_texture is NOT SUPPORTED
INFO: GL_ARB_clip_control is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available

Buggy driver detected. Geometry shaders will be disabled
Buggy driver detected, GL_ARB_separate_shader_objects will be disabled

I think, I have just successfully managed to make it work. Seems like there is kind of a bug. When I resize the window with a game, the graphics just appears. Strange, right?

EDIT: And I have also noticed I get just the same FPS rate with the integrated and the dedicated GPU, when using the HW mode. I find this odd, too. Here's the output of the integrated GPU:
Code:
    Opening GS
Current Renderer: OpenGL (Hardware mode)
glX-Version 1.4 with Direct Rendering
OpenGL information. GPU: Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2. Vendor: Intel Open Source Technology Center. Driver: (Core Profile) Mesa 11.2.0
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_draw_buffers_blend is available
INFO: GL_ARB_separate_shader_objects is NOT SUPPORTED
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_copy_image is available
INFO: GL_ARB_buffer_storage is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_clip_control is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available

Buggy driver detected, GL_ARB_separate_shader_objects will be disabled
Seems like the Intel GPU supports more features.
Reply
#4
Could you update to mesa 12.x ? Potentially it will fix your bug and it will be faster.

If you use a native resolution, you will be mostly limited by the CPU, i.e. the driver overhead. You could try to disable some accurate options to reduce the driver load such as "accurate blending" "accurate date"
Reply
#5
Okay, updated to Mesa 12.0.1, but the log seems to show the same result as before:
Code:
    Opening GS
Current Renderer: OpenGL (Hardware mode)
glX-Version 1.4 with Direct Rendering
OpenGL information. GPU: Gallium 0.4 on AMD OLAND (DRM 2.43.0 / 4.4.0-31-generic, LLVM 3.8.1). Vendor: X.Org. Driver: (Core Profile) Mesa 12.1.0-devel
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_draw_buffers_blend is available
INFO: GL_ARB_separate_shader_objects is NOT SUPPORTED
INFO: GL_ARB_shader_image_load_store is NOT SUPPORTED
INFO: GL_ARB_copy_image is available
INFO: GL_ARB_buffer_storage is available
INFO: GL_ARB_clear_texture is NOT SUPPORTED
INFO: GL_ARB_clip_control is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available

Buggy driver detected. Geometry shaders will be disabled
Buggy driver detected, GL_ARB_separate_shader_objects will be disabled
Games are, indeed, little faster now, but the black window bug persists. I though the Intel i5-3230M (2.6 GHz, TB 3.2 GHz) was sufficient for PS2 emulation, but I didn't know, if the AMD HD8750M was powerful enough for this stuff, though. I guess 4 GB of RAM is OK.

Today we also tested the emulator on my brother's desktop (Win 7, i7-2600, nVidia GT640 OC 2GB) and all games worked flawlessly, whereas I only get about 30 - 40 FPS.

I don't think there's a big difference between the two GPUs, so maybe the CPU is really the weakest link in the chain? Just to specify, we tried Tekken games.
Reply
#6
Yes Nvidia driver is miles ahead. Tekken5 is normally faster on latest GSdx git.

For the black screen issue, i don't have any clue
Reply
#7
Alright, thanks for your effort, your advices have been the most helpful for me so far. :-) Maybe I should try downgrading to Ubuntu 14.04 / Mint 17 and use AMD fglrx proprietary drivers.
Reply




Users browsing this thread: 1 Guest(s)