Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unable to Launch Game (Star Ocean 3)
#1
All,

I am having difficulty launching Star Ocean 3 from disc or from ISO. I installed a PS2 BIOS and I can launch BIOS just fine. Can some one take a look at my X11 text and see if they can help? Many thanks.

I am running OSX 10.7.4, MacBookPro 2.5GHz Core 2 Duo, 6GB RAM, NVIDIA GeForce 8600M GT 512 MB

F1 - save state
(Shift +) F2 - cycle states
F3 - load state
PCSX2 beta (r2620254) - compiled on Jan 27 2011
Savestate version: 8b410001
EE pc offset: 0x2a8, IOP pc offset: 0x208
x86Init:
Features:
Loading plugins...
Loading GS...
Loading PAD1...
Loading PAD2...
Loading SPU2...
Loading CDVD...
Loading DEV9...
Loading USB...
Loading FW...
Plugins loaded successfully.
Resetting...
Ready
Initializing plugins...
Plugins initialized successfully.
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2274624 sectors)
Bios Version 1.60
Bios Warning > rom2 not found.
Bios Warning > erom not found.
Framelimiter rate updated (UpdateVSyncRate): 59.94 fps
Opening Plugins...
Notice: GS Plugin does not implement GSsetFrameLimit.
MTGS > Thread Started, Opening GS Plugin...
ZZogl: Using ZZ Ogl :0.21.213
ZZogl: creating zerogs
ZZogl: Got Doublebuffered Visual!
ZZogl: glX-Version 1.4
Xlib: extension "XFree86-VidModeExtension" missing on display "/tmp/launch-v7RU78/org.x:0".
ZZogl: Depth 24
ZZogl: you have Direct Rendering!
ZZogl: Using multitexturing
ZZogl: Maximun texture size is 8192 for Tex_2d and 8192 for Tex_NV
ZZogl: Disabling MRT depth writing
ZZogl: Fill bilinear blocks failed!
ZZogl: Creating effects
ZZogl: Creating extra effects
ZZogl: using full shaders
ZZogl: initialization successful
ZeroSPU2: Initialized portaudio...
ZeroSPU2: Created sound stream successfully...
ZeroSPU2: Started sound stream successfully...
Plugins opened successfully.
loadElfCRC: cdrom0:\SLUS_204.88;1
loadElfFile: 750512 bytes
loadElfFile: cdrom0:\SLUS_204.88;1; CRC = 23A97857
XML Loader returned an error. Trying to load a pnach...
No patch found.Resuming execution without a patch (this is NOT an error).
ZZogl: Disabling MRT depth writing
Issuing EE/iR5900-32 Recompiler Reset [mem/structure cleanup]
vtlb/mmap: Block Tracking reset...
iR3000A Resetting recompiler memory and structures
* PCSX2 *: ExecuteBios
# Initialize memory (rev:3.63, ctm:393Mhz, cpuclk:295Mhz detected)
# Total accessable memory size: 32 MB (B:2:8:0) (363:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb 7 2002 16:41:20
CPUID=2e20, BoardID=0, ROMGEN=2002-0207, 32M

# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Issuing EE/iR5900-32 Recompiler Reset [mem/structure cleanup]
vtlb/mmap: Block Tracking reset...
* PCSX2 *: ExecuteBios Complete
loadElfFile: cdrom0:\SLUS_204.88;1
Loading from a CD rom or CD image
loadElfFile: 750512
addr 15388 "rom0OhmySDSYS" -> "cdrom0:\SLUS_204.88;1"
addr 15b00 "rom0OhmySDSYS" -> "cdrom0:\SLUS_204.88;1"
addr 215d8 "rom0OhmySDSYS" -> "cdrom0:\SLUS_204.88;1"
addr 90780 "rom0OhmySDSYS" -> "cdrom0:\SLUS_204.88;1"
loadElfFile: cdrom0:\SLUS_204.88;1; CRC = 23A97857
XML Loader returned an error. Trying to load a pnach...
No patch found.Resuming execution without a patch (this is NOT an error).
Opening Plugins...
Plugins opened successfully.
ZZogl: Disabling MRT depth writing
vtlbDefaultPhyRead32: 0x5FE2D00
Offset 0xea00ffff invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2: 4256 Bus error: 10 ./pcsx2
Reply

Sponsored links

#2
There's a special tri-ace fix to enable.
Not sure it exists in the mac port, though
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(06-04-2012, 12:07 AM)jesalvein Wrote: There's a special tri-ace fix to enable.
Not sure it exists in the mac port, though

Thanks for the reply. I enabled the Tri-Ace Game Fix and unfortunately it did not help. Here is the error portion of the X11 Window:


ZZogl: Disabling MRT depth writing
vtlbDefaultPhyRead32: 0x5FE2D00
Offset 0xea00ffff invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2: 400 Bus error: 10 ./pcsx2
Reply




Users browsing this thread: 1 Guest(s)