Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unable to run in Direct3D9 (hardware) or Direct3D11 (Hardware)
#1
Dear PCSX2 crew,

I have spent several days modifying my application and were finally able to launch
Battlefield 2: Modern Combat, now to the problem(s).

Questions:
- How come I can't run this game in Direct3D9 or in Direct3D11 (Hardware)?
- How come my game keeps lagging when being run in D3D9 or D3D11 (Software)?

Computer Hardware:
Intel-Core i7-2600k @ 4.7GHz v1.340 (Hyperthreading enabled)
XFX AMD HD6970 2GB @ 1000/1500 v1.24 (AMD CCC 12.4)
All drivers and updates up-to-date!

Application version PCSX2 r5160 and settings:
[Image: 80189764.jpg]
[Image: 15794106.jpg]
[Image: 18421750.jpg]
[Image: 666fz.jpg]
EE: 15%
GS: 90%
VU: 15%
UI: 10%

When I choose to launch my game in Direct3D9 or Direct3D11 (Hardware)
I won't be able to choose my language or the 50Hz/60Hz monitor settings,
not a big problem but the same goes for the main menu which result in a
''black screen'' not able to navigate or play the game:

Language selection and monitor settings in Direct3D9 and Direct3D11 (Hardware):
[Image: 0000ue.jpg]
1st picture, I'll get pass this by simply pressing the ''X-button'' but this solution will not
do for the
main menu where it simply won't accept any command once in the main menu.

Main menu in Direct3D9 and Direct3D11 (Hardware):
[Image: 0001gk.jpg]
2nd picture, unable to press the ''X-button nor Start'', commands not accepted.

This is how the game looks like when being run in Direct3D9 and Direct3D11 (Software),
Language selection in and Direct3D11 (Software):
[Image: 0002up.jpg]

Monitor settings in Direct3D9 and Direct3D11 (Software):
[Image: 0003tz.jpg]

Main menu in Direct3D9 and Direct3D11 (Software):
[Image: 0004ja.jpg]

Battlefield 2 Modern Combat on PC in Direct3D9 and Direct3D11 (Software):
[Image: 0005rx.jpg]

Sponsored links

#2
Well, First try reduce Speedhacks. and please show the configuration of GSDX.

Software mode is more accurate but slower as it uses your CPU not GPU. Try increasing the rendering thread for Software. Well, software mode is always a bit laggy for the same reason.
[Image: recodersignature2.png]
#3
(04-24-2012, 07:27 PM)recoder Wrote: Well, First try reduce Speedhacks. and please show the configuration of GSDX.

Software mode is more accurate but slower as it uses your CPU not GPU. Try increasing the rendering thread for Software. Well, software mode is always a bit laggy for the same reason.

More settings, but lowering the speed hacks will make it run even slower
and what do you mean with ''try increasing the rendering thread for software'',
where can I do that and will that have an major performance impact?

Please don't be fooled by Fraps ''60FPS'' the game is actually running at MAX 5-10FPS!Tongue
Any ideas on how to run this a ''little bit'' faster?
[Image: 62655456.jpg]
[Image: 30767340.jpg]
[Image: 15775004.jpg]
#4
you could start by proving us you own 6 pS2s, especially 2 from the same region ...
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)