Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upgraded graphics card now lags and everything?
#1
So I was able to play just fine a couple days ago with my old card gtx 260 no frame rate issues for the game I am playing and I installed my new graphics card today (gtx 570) and now it lags a lot and I can't seem to edit anything in the video settings like I could before.

So it seems the emulator doesn't realize I have a graphics card is my conclusion (could be wrong) and now need to figure out how to make it recognize it or whatever.

gtx 570
4 gigs of DDR2 ram
Intel quad Q8400
Windows 7 ultimate 64 bit

I mean literally worked 2 days ago with the same game and the only difference was it was a gtx 260 not a 570. For those curious its for the game wild arms 3. Thanks in advance for anyone who can help me out!
Reply

Sponsored links

#2
try updating ur drivers and if that dont work, try a old version of the nvidia drivers.
Reply
#3
does your windows recognize the Card well. Check that you have updated your drivers. Was your GTX 260 overclocked.
[Image: recodersignature2.png]
Reply
#4
Maybe try removing the emulator completely, and removing all registry entries for it too. Then reboot and reinstall, as I had a similar problem with (of all things) a Megadrive emulator. Worked when I fresh installed it.
OS: Windows 7 Ultimate 64-Bit (6.1, Build 7601)
Processor: Intel® Core™ i5-2500k CPU @ 3.30GHz (4CPUs), ~3.6GHz
Memory: 4096MB RAM
DirectX Version: DirectX 11
GFX Card: NVIDIA GeForce GTX 560 Ti
Sound: Realtek HD Audio (Onboard)
Reply
#5
Depending on the game, it has been found that nvidia Fermi gpu's are explicitly more bottlenecked on Core 2 and AMD cpu's than pre fermi parts.

IE, CPU is being utilised more by the driver to try and drive the GPU leaving the Main threads starved.
Reply
#6
(09-29-2011, 10:06 AM)recoder Wrote: does your windows recognize the Card well. Check that you have updated your drivers. Was your GTX 260 overclocked.


My 260 was "super clocked" when I bought it or whatever just like this one is. And yes windows recognizes it and I play a bunch of pc games and working like a charm.
Reply
#7
So you need to overclock your GTX 570.
[Image: recodersignature2.png]
Reply
#8
(09-30-2011, 09:52 AM)recoder Wrote: So you need to overclock your GTX 570.

Well my 570 is also superclocked. Same deal as 260 by same company where they overclock it themselves. I'm going to try reinstalling today hope it works.
Reply
#9
(09-29-2011, 03:30 PM)Squall Leonhart Wrote: Depending on the game, it has been found that nvidia Fermi gpu's are explicitly more bottlenecked on Core 2 and AMD cpu's than pre fermi parts.

IE, CPU is being utilised more by the driver to try and drive the GPU leaving the Main threads starved.

Maybe in PC games, but in pcsx2 I doubt that. If what you say is true, then mind telling me what games are those?
Reply
#10
(09-29-2011, 09:33 AM)blade55555 Wrote: So I was able to play just fine a couple days ago with my old card gtx 260 no frame rate issues for the game I am playing and I installed my new graphics card today (gtx 570) and now it lags a lot and I can't seem to edit anything in the video settings like I could before.

So it seems the emulator doesn't realize I have a graphics card is my conclusion (could be wrong) and now need to figure out how to make it recognize it or whatever.

gtx 570
4 gigs of DDR2 ram
Intel quad Q8400
Windows 7 ultimate 64 bit

I mean literally worked 2 days ago with the same game and the only difference was it was a gtx 260 not a 570. For those curious its for the game wild arms 3. Thanks in advance for anyone who can help me out!


I dont get that I have 9800GT and the moment I upgraded to 460 I saw a huge increase in performance in pcsx2. I would think the 560 hell the whole 5xx series would be the same.

I would try to remove pcsx2 get fresh new copy and try again.
Reply




Users browsing this thread: 1 Guest(s)