Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upscalling PCSX2?
#1
Video 
Is there anyway to upscale the emulator to make it look better? I looked online and haven't really found anything that works. I've saw a few youtube videos and the games look pretty damn good. Maybe I'm just doing something wrong because my games look pixelated. Any help would be highly appreciated.

PC Specs
i5-6600K @4.5GHz
Gskill 2x8GB DDR4 2400MHz
GTX 960 4GB
PCSX2 1.4.0


[Image: lGLHVBt.png]

[Image: GBE4eRi.png]
Reply

Sponsored links

#2
You can't upscale 2D. The in-game 3D will be though.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Go to Config > Video (GS) > Plugin Settings and set the Internal Resolution to any of the ..x native resolution to use the upscaling.

You can make some 2D pixels look a little better by setting the Texture Filtering to "Bilinear (Forced)".
Reply
#4
(10-11-2016, 02:05 PM)krzyimprt Wrote: Is there anyway to upscale the emulator to make it look better? I looked online and haven't really found anything that works. I've saw a few youtube videos and the games look pretty damn good. Maybe I'm just doing something wrong because my games look pixelated. Any help would be highly appreciated.

PC Specs
i5-6600K @4.5GHz
Gskill 2x8GB DDR4 2400MHz
GTX 960 4GB
PCSX2 1.4.0


[Image: lGLHVBt.png]

[Image: GBE4eRi.png]

Well, upscale basically means stretch, which is what's making 2D stuff look bad here. Can't really do anything about that. Actually forcing bilinear filtering might help if you like that look.
As a side note though, we don't really recommend using custom resolution in GSdx, games work better using multipliers under internal resolution.
Reply




Users browsing this thread: 1 Guest(s)