Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Urban Chaos Riot Response: Screen flashing white every few seconds
#1
I'm using the latest development build for that game. Framerate is pretty good at native resolution in OpenGL Hardware mode (50-60 fps most of the time - with flashlight on it's 45 fps).
But every few seconds the screen flashes white. It's not really game breaking, but is there a workaround for that issue, or are there any special settings for that game?


My specs:

AMD Phenom II X6 1055T (6x 2.8 GHz)
8 GB DDR3 RAM
ATI Radeon HD 5850 1GB VRAM
Windows 10 Pro 64Bit


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
If you want more speed, reduce the level of blending accuracy. What hw hack did you enabled ? Did you enabled hack on the core (EE/VU cycle)?
Reply
#3
Thanks, reducing the level of blending accuracy to "none" did help - nice speedup  Smile

I didn't enable any hardware hack, just forgot to untick the checkbox (i'm using hacks for another game)  Tongue
Well, i have to admit, that i'm using speedhacks. I've set the preset slider to 4 (aggressive)... Maybe that's causing the problem with the white flashing screen?
Reply
#4
With AMD driver, BA == low could be doable without a big perf impact in most games (some game will be slow even with a good driver).

I don't know, but recent GSdx is more sensible to hack from the core. The best is to try with the safest preset. Then if it work, try less safe preset. Rendering of the game was fixed not long ago but you're first one to complain about white screen issue. (could be a regression on latest git too).
Reply
#5
Well, setting the speedhacks preset to 1 fixed the white screen issue  Smile

The framerate was still good. But after i loaded the 2nd level of the game, the framerate went down to around 30 fps  Laugh Rolleyes

My pc (mostly the cpu) is too weak for this game i guess, or the game is too demanding in terms of emulation.

I will keep playing this game on my PS2 - perfect graphics and perfect framerate  Biggrin Only the resolution is a "bit" low  Wacko

Thanks anyway for your help  Smile
Reply
#6
Honestly you could increase the upscaling, it won't hurt. You don't see it but the game generate a tons of geometry. On the GS side it ought to be fast enough nowadays.

(disable preset) Try to use MTVU or to enable the speed hack on the VU. There are lots of variation between 1 and 4, the trick is to find the good and the back speedhack Wink
Reply
#7
Ok, i've tried different speedhack combinations, but i'm not able to achieve a stable/playable framerate...
Onscreen it says 60 fps, but it's definitely not 60 fps. It feels like 15-20 fps - laggy as hell.
Like i mentioned, the 1st level is perfectly playable, but after that the game get's totally unplayable.
Reply




Users browsing this thread: 1 Guest(s)