Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
V-Sync Enabled, But Still Tearing
#1
PC Specs:

Windows 7 Ultimate 64-bit
i7 2600k @ 4.8Ghz
8GB 2134Ghz Evo Corsa RAM
GTX690
Latest Drivers, tested beta drivers as well but no help.
2 x Monitors at 1920 x 1200. Tested with only 1 monitor plugged in as well.

Trying to play Kingdom Hearts but I have ridiculous screen tearing issues. This is with v-sync enabled in the latest official release and tested in the latest beta release r3566.

I've tried turning on v-sync in nVidia inspector and nvidia control panel to no avail. I've tried turning it off and only on in PCSX2. I've tried turning it off in PCSX2 and on only in the control panel. I've tried d3d9 (tears at the bottom, usually) and d3d11 (tears near the top, usually).

I seem to be unable to v-sync to work in all tests. Am I missing something or do nVidias drivers just suck? My PC can handle anything thrown at it, but it just doesn't seem to like vsync in pcsx2. It also has issues with v-sync during videos. Games like BF3 have no v-sync issues.
Reply

Sponsored links

#2
maybe kingdom hearts doesnt use v-sync?
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#3
Well. I found an inelegant solutions using some of the older GSdx plugins. What seems to be happening is that PCSX2 1.0.0 and 1.1.0 aren't actually managing the v-sync for whatever reason. I need a GSdx plugin with integrated v-sync, otherwise it just won't work.

However this seems to cut out a good cut of features such as the ability to add AA and what not.
Reply
#4
um... enable DWM and you don't need vsync.
Reply
#5
DWM is enabled, but tearing still occurs on the newest plugins.
Reply
#6
What internal resolution are you currently using? Is the game 4:3 or 16:9?
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#7
(08-12-2012, 04:30 PM)hyperionxl Wrote: DWM is enabled, but tearing still occurs on the newest plugins.

Does it happen all the time or only occasionally?
Reply
#8
4x - 6x. Running fullscreen 1920 x 1200 rez. 16:9 on PCSX2

All the time.

It's most likely a driver incompatibility with the GTX690. I'm using the old GS plugins with no tearing. The new plugins tear at any setting.
Reply
#9
Why not 1920x1080?

Did you try some MSAA? Or maybe enabling 8-bit textures and texture filtering?
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#10
Because my monitors are 1920 x 1200. PCSX2 makes full use of the monitor.

None of those features would make a difference to v-sync being enabled and working or not. It's a GPU/driver/plugin issue, most likely with the GTX690.
Reply




Users browsing this thread: 1 Guest(s)