Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Valkyrie Profile Silmeria 2 performance issues
#1
Hello all

Im somewhat of a noob with PCSX 2, but I've seen video's of people running this at full 60 FPS

I'm wondering if people can help me out to get similar performance

MY PC Specs are :

Processor - AMD PhenomII FX 6100 6 core at 3.3ghz
Ram - 8GB DDR3
Video card - Nvidia GTX 465

GSD setting for resolution is native on DX9 hardware

Ive enabled the MTVU multicore option and have my presets to aggresive for speedhacks, and max I get is around 50 FPS which dips considerably the more stuff is onscreen, not sure what I can do, if anyone can help?

Im running PCSX 1.0 r5350
Reply

Sponsored links

#2
this particular game is known to be amazingly demanding.
Unfortunately, your CPu won't help.
you can set skipdraw to 1 to make it playable, but you'll get glitches during battles.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(12-06-2012, 09:00 PM)jesalvein Wrote: this particular game is known to be amazingly demanding.
Unfortunately, your CPu won't help.
you can set skipdraw to 1 to make it playable, but you'll get glitches during battles.

I was wondering, the Wiki said that, I added allowhacks=1 to the GSD ini, but i cant find a skipdraw option, where do I find this? Is it the option under frame skipping where you have the skip and draw options? do I set that to 1?
Reply
#4
Open GSdx plugin settings, check Enable HW hacks and open the HW hacks config box with the button next to it. You can set it there.
Reply
#5
@Thanktos2,


You sure you are on pCSX2 1.0.0 and have had no RED GSdx screen issues!!!??

Like this ↓ Glare
[Image: 11621571.jpg]

What GSdx settings are you using !?? Are u using manual game fixes ?


Well darn it... although my HD6870 seriously OUTPERFORMS your GTX465 card i have all kind of graphics garbage in one game or another ...

But VP2 takes the cake Huh !!!

My copy of VP2 is:
SLES_546.44 / PAL


cherriepoppers,
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 965BE@4.1GHZ stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1
Reply
#6
SkipDraw set to 1 gave me no performance increase at all Sad what am I doing wrong? Ive seen vidoes of ppl on youtube with systems not as good as mine playing this at 60 FPS steady....

According to the Wiki :

PCSX2 version: r1888
Graphics by GSDX: 2660
Sound by SPU2: SPU2-X r2663 1.4.0
Pad plugin is LilyPad: (r1853) 0.10.0
DVD plugin is Linuz ISO: 0.8.0
BIOS version: Any

CPU: Intel Core i7 920 @ 3.6GHz
GPU: EVGA GTX 275 CO-OP PhysX Edition 1280mb

Comments: Very Intense game, needs a fast CPU and GPU. It will need at least a Core 2 duo @ 3.4GHz and a 9600GT or equivalent to maintain full speed throughout the game. However, the game has some bugs and will drop FPS to around the 20-50 range due to some errors and whatnots not yet fixed in this Revision of the emulator. Don't worry, it only happens in some areas of the game. To know more scroll down to see the Known Issues below. You can also hold triangle and X buttons while the game boots up to enable 525p mode in full/widescreen so interlacing can be disabled.

My Processor isn't quite as good as that I7, but it's not a huge degree worse, and my videocard is better, i cant see why im having such significant performance issues...

@Metagondria

Im working off default settings off fresh install of PCSX2, other then speed hack changes in config window, and the recommended skipdraw setting, Ive never run into that red screen issue
Reply
#7
that GPU is weak, whatever you think (it may be slightly better than the 9600, though...)
if you set skipdraw to 1, make sure you keep native res.
and unfortunately, your CPu isn't made for gaming.
bulldozer architecture is known to perform very badly under pcsx2...
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
(12-07-2012, 12:30 AM)Thanatos2 Wrote: @Metagondria

Im working off default settings off fresh install of PCSX2, other then speed hack changes in config window, and the recommended skipdraw setting, Ive never run into that red screen issue

I used most compatible and safest setting (accordin to pCSX2)!!
Not that much you can config wrong in pCSX2 is there ?!!

But tell me in what pcsx2 version did you run VP2 fine ?

I read you have tried the latest official pcsx2 release r5350, and afterwards rolled back to r1888 ?
r1888 is that 0.9.x.x builds ?

Have you tried SVN build r5452 yet ?

Using r5452 fixed an issue ingame suikoden Tactics Biggrin

The FPS in VP2 is just perfect.. 50 FPS /pal full speed here... its just when i start the 1st dungeon i get that red screen !?

..maybe Ati is making an mess of things again.. Its known to happend before with epsx (PS1 emu) !!

Back then i had to use d3d.dll and opengl.dll driver from old ati pack archives to get rid of graphics glitches in FFVIII !!



(12-07-2012, 12:39 AM)jesalvein Wrote: that GPU is weak, whatever you think (it may be slightly better than the 9600, though...)
if you set skipdraw to 1, make sure you keep native res.
and unfortunately, your CPu isn't made for gaming.
bulldozer architecture is known to perform very badly under pcsx2...

I have read (been told) that skipdraw is never recommended due to the way ps2 console handles it poorly !?

Bulldozer is indeed an FAildozer according to benchmarks and what not

But i nor attonostank have a Bulldozer cpu ?

Atostank his/her cpu is not even AMD Glare ?

You sure you posted in the right thread Blink ?

cherriepoppers,
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 965BE@4.1GHZ stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1
Reply
#9
Just found out by switching to SW mode it fixed the Red screen... But fps is unplayable painfull slow !!!

And it looks like ps1 graphics . bah..!!!!

Something to do with the Gsdx plugin i asume !!


oh well..
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 965BE@4.1GHZ stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1
Reply
#10
Quote:But i nor attonostank have a Bulldozer cpu ?

Atostank his/her cpu is not even AMD ?

You sure you posted in the right thread ?

hem...

Quote:MY PC Specs are :

Processor - AMD PhenomII FX 6100 6 core at 3.3ghz

Yes I am.

though, I wonder what his cpu is, since it should be either an FX6100 or a Phenom II. But not both at the same time.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)