Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Very Slow Gameplay
#1
Running pcsx2-git 1.5 in Manjaro Linux. It's very slow. MGS2 is virtually unplayable with the rain on the tanker at the beginning of the game. Xenosaga Episode III is playable but still slow. Hardware: i3-6100, intel hd520 gpu, 8GB DDR4-2133. Would a different video plugin help?

https://imagebin.ca/v/2xDc6paDLpjk
Reply

Sponsored links

#2
Maybe you could use the openGL HW renderer (at the top). I would suggest to get latest Mesa too.
Reply
#3
(10-03-2016, 08:00 PM)gregory Wrote: Maybe you could use the openGL HW renderer (at the top). I would suggest to get latest Mesa too.

Thanks for replying Gregory. The HW renderer has the same issues, but it also puts a diagonal orange and blue line down the screen. I believe my mesa is up to date. 
I would really like to try another video plugin. In Xenosaga III the font is all messed up too.
Reply
#4
GSdx is the fastest and accurate GS plugin in the world. Which setting did you put in the advance setting panel? What is your exact mesa version. Set blending accuracy to disable.

Quote:The HW renderer has the same issues, but it also puts a diagonal orange and blue line down the screen.
I would need a screenshot but it feels a bug in Mesa. Try to disable the geometry shader extension in the advance settings panel.
Reply
#5
Here are my advanced settings: https://imagebin.ca/v/2xocSpQlpA4g
settings: https://imagebin.ca/v/2xocfwRkWAAE

Setting blend accuracy to disable and geomety shader extension to disable fixed the diagonal line going down the screen. Thanks.
But it still runs at about 50% speed.
Im using mesa 12.0.3-1
Reply
#6
I'm not sure if you can improve hardware mode performance that much with that iGPU. MGS2 can be quite demanding.

You can set the extra rendering threads to 3 or 4 and see if that gets you enough speed in software mode.
Reply
#7
MGS might be heavy on the VU side too, might need to use speedhack. Otherwise on the GS side, you can try to disable depth support and set CRC hack to full.
Reply
#8
(10-09-2016, 10:22 AM)FlatOut Wrote: I'm not sure if you can improve hardware mode performance that much with that iGPU. MGS2 can be quite demanding.

You can set the extra rendering threads to 3 or 4 and see if that gets you enough speed in software mode.

MGS2 played fine in OSX on a Radeon HD6750M.
My integrated Intel HD530 plays other games at similar or slightly higher frame rates than the HD6750m. I bet if I had Windows or OSX installed on my HD530 machine PCSX2 would run fine.

Xenosaga frame rates.  It's only this slow during certain cutscenes.
https://imagebin.ca/v/2xrickzT2lao
Reply
#9
And did you try to disable the depth support on the GS plugin. It is quite costly for the GPU.
Reply
#10
(10-09-2016, 12:15 PM)Grahf Wrote: MGS2 played fine in OSX on a Radeon HD6750M.
My integrated Intel HD530 plays other games at similar or slightly higher frame rates than the HD6750m. I bet if I had Windows or OSX installed on my HD530 machine PCSX2 would run fine.
Just because it runs some games at similar or highter framerates, doesn't mean that will apply to all games. My iGPU runs some games better than my AMD GPU on Windows as well, but for most games it's much slower. And if you used an OSX version of PCSX2 that would've been a very old version, and older versions of PCSX2 are usually faster because they're less accurate.
Reply




Users browsing this thread: 1 Guest(s)