Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Very specific lagging in MGS 2: Substance
#1
I've been trying to run MGS 2 on PCSX2 but I'm having some issues. Whenever I change to first person view, the game lags to an unplayable state for a few seconds and the audio buzzes. This also occurred a few times during the first cut-scene. I was wondering if my specs might be the issue or if there are some settings I could change? I first tried running it with all default settings and then tried decreasing audio quality and enabling MTVU. Thanks in advance!
Specs are as follows: 8 GB DDR3 Ram, AMD FX™-6350 Six-Core Processor (3.90 GHz), AMD Radeon R9 200 Series GPU
Also, I'm running version 1.4.0.
Reply

Sponsored links

#2
What are the EE/GS % when this occurs. I am guessing that it spikes pretty high since your CPU is under what would be recommended to most games and well under the performance levels to run demanding ones (like the Metal Gear games).
Reply
#3
For me it's stealth camouflage causing massive lag.

In the first cutscene there was stealth as well when Snake first gets on the tanker. I used skipdraw to get around the stealth lag issue. You can give that a try to see if it improves things.

But yeah. MGS2 is easily one of the most demanding games on PCSX2. One of the rare few games where I actually had to resort to using speedhacks.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply




Users browsing this thread: 1 Guest(s)