Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Virtua Fighter 4 Running at 89-120fps HELP!
#1
So as you can tell im new to the forums and i've been messing around with the PCSX2 1.0.0 settings. At one stage the game was running at 800-1150 fps >< i almost fell off my chair!

How on earth do i get this game to slow down to 60fps?
So far i have tested Kingdom Hearts I+II , GT4 , Virtua Fighter Evo and they all worked fine with my default settings after downloading PCSX2 1.0.0

My computer specs are
Intel® Core™ i7-3770K CPU @ 3.50 GHz, 3901 Mhz, 4 Core(s), 8 Logical Processor(s)
Nvidia Geforce GTX 680
RAM 16.0 GB
Windows 7 x64Bit

Is there something i can do or is it my machine ?
Help please Laugh thanks

-BzBman8
Reply

Sponsored links

#2
You can either (or both) enable VSync in your gpu control panel, and or go into the pcsx2 config->GS, and ensure 'Disable Framelimiting' is not ticked.

Try that and see if it sorts it, if it doesn't post your current settings and i'll have a look.
Reply
#3
Ok i have absolutely no idea on what i did. Actually i really didnt do anything. All i did was remove speed hacks then reset pcsx. Nothing happened. I enabled it again then reset... Nothing happened. Changed my framelimiter to 10% for all 3 stats and reset.. Nothing Happened. Then with all Base framerate+Slow Motion+ Turbo set to just 10% each and the framerate still killing 120fps i turned speedhacks off then reset. Ok now im running at 6FPS! So i upped my 3 framerate stats back to default (Base FR 100% , SM 50%, Turbo 200%) then reset with speed hacks still turned off.... Nothing happens im still at 6FPS >< so i turn speed hacks back on and now im at 60fps ????

But all i did was return it back to the way it was! Rofl beats me. So long as the frame Limiter reads normal always and not turbo then im happy.
That was the problem, while playing the game on the screen it said [limiter: Turbo] Now its reading Normal and not turbo so the game is running at normal speed.
/EDIT: I had tried setting turbo to 100% down from 200% and reset pcsx2 prior to all this testing to see if it did anything. It did not.

Is there something i have done that i have forgotten about that has turned the turbo off?
Thanks for the reply!

-BzBman8
Reply
#4
You probably hit tab to enable turbo, or somethin. You should use a Settings preset (checkbox at the bottom of the pcsx2 config window) Don't go past the balanced preset for general use though.
Reply
#5
Well, the answer may be in you enabled the "disable framelimiting" at the GS config tab.

I know, it is confusing sometimes, to have framelimiting (that forces the game to run at 60FPS or 50FPS depending on NTSC or PAL) you need not to disable it, what means that little box must be blank.

PS: another answer would be you must have pressed F4 (what does the same as above but is valid only for the current session and returns to whatever is on that little box the next time you reload the emulator). That means you can use F4 to temporarily toggle the framelimiting on/off, one usage is for benchmark... not much beyond this.

PS: Is beyond this thread scope but may be helpful a short explanation about the turbo and the framelimiting usage.

The turbo, activated by the Tab key tries to make the game going faster than normal, useful for quickly passing boring scenes. It works well with that option to activate frame skipping only on turbo, for this effectively increases the FPS beyond what would be normally possible at the cost of losing accuracy.

Shift + Tab works the inverse as the turbo by forcing a lower FPS (slow motion), useful in some minigames inside the main game.

The framelimiting should not be touched unless for benchmark purposes for it makes the play too erratic. It may provide a small performance gain but too small for the cost, I fear.

None the two, framelimiting or turbo should be used as speedhacks... they aren't meant to this. You can try it but should be the last thing after all actual speedhacks were attempted.
Imagination is where we are truly real
Reply
#6
Im not sure what was wrong, but disabling framelimiting is just suicidal as it plays at over 200fps and the menu's are at over 1000fps(quite funny trying to watch the load up fights). As asmodean mentioned it must have been from turbo being turned on from tab. I never press tab/F4 for any reason so i guess this game just chose to load with turbo turned on instead of running at normal framerate. Asmodean also mentioned in using a settings preset so this doesn't happen to me again.

Thanks all for the help Laugh i really appreciate the replys. Everything has been running smoothly and im finally training my A.I so i can enjoy fighting it!
Looking forward to experimenting with more games
Reply
#7
I had Virtua Fighter 1 for the Sega Saturn back in the day, each model had about 4 polygons, was a good game Tongue The drunk guy was awesome.




typooo
Reply
#8
(12-05-2012, 05:30 PM)BzBman8 Wrote: Im not sure what was wrong, but disabling framelimiting is just suicidal as it plays at over 200fps and the menu's are at over 1000fps(quite funny trying to watch the load up fights). As asmodean mentioned it must have been from turbo being turned on from tab. I never press tab/F4 for any reason so i guess this game just chose to load with turbo turned on instead of running at normal framerate. Asmodean also mentioned in using a settings preset so this doesn't happen to me again.

Thanks all for the help Laugh i really appreciate the replys. Everything has been running smoothly and im finally training my A.I so i can enjoy fighting it!
Looking forward to experimenting with more games

Actually you should not activate any preset, enjoy the opportunity to look at the speedhacks and make sure none other than the recommended are turned off. that machine is a monster
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)