Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WAY too slow for my specs. What's wrong?
#1
Good evening.

I realize stuff like this gets asked a lot, but I didn't find a solution in existing threads.

I got a kinda new machine:
CPU: AMD FX-8350 8x 4.0 GHz
GPU: Radeon R9 380
RAM: 12GB DDR3
OP: Win7

It can handle The Witcher 3 very well. But I just popped in Shadow Of The Colossus, and in default settings and *without speed hacks* it's in total slow motion. I strongly feel it shouldn't be. I gets playable with EE -1 und VU 2 but looks choppy af. I even think it actually ran better on my older PC.

I tried it in AVX, SSE4.1 SSSE3 (slightly less bad, still bad), I tried Direct3D9 hw and Direct3D11 hw (shadows gone, still slow). Tried with and without hardware hacks, fooled around with everything I could think of... I still feel like some major thing isn't working properly, I just can't find anything.

I mean, I've seen people getting a fine performance even with EE +2 on that game. Or is this only possible with Intel + NVidia?
Reply

Sponsored links

#2
(07-26-2016, 08:53 PM)theeda Wrote: Good evening.

I realize stuff like this gets asked a lot, but I didn't find a solution in existing threads.

I got a kinda new machine:
CPU: AMD FX-8350 8x 4.0 GHz
GPU: Radeon R9 380
RAM: 12GB DDR3
OP: Win7

It can handle The Witcher 3 very well.
totally irrelevant. The witcher 3 isn't an emulated game.

Quote:I strongly feel it shouldn't be. I gets playable with EE -1 und VU 2 but looks choppy af. I even think it actually ran better on my older PC.
1 - what was you older PC ?
2 - Why do you think it shouldn't be ?
3 - Tried the game on your PS2 before saying it's "choppy" ?

Quote:I tried it in AVX, SSE4.1 SSSE3 (slightly less bad, still bad), I tried Direct3D9 hw and Direct3D11 hw (shadows gone, still slow). Tried with and without hardware hacks, fooled around with everything I could think of... I still feel like some major thing isn't working properly, I just can't find anything.

I mean, I've seen people getting a fine performance even with EE +2 on that game. Or is this only possible with Intel + NVidia?

nope.
mainly, disable mtvu speedhack + set vu cycle stealing to 1 or 2. it should be fine this way
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Thanks for replying.

I'm embarrassed.

I was blind and got confused.

All is fine now.


I had seen a video where a guy was demonstrating his settings for the game, and it *looked* like he was applying a speedhack of EE +2 on a PC weaker than mine, but it was an older version of pcsx2 with a different layout. It was actually EE -2. If I do that, I get good results.

But I will disable mtvu, thanks.
Reply
#4
(07-27-2016, 12:10 PM)theeda Wrote: Thanks for replying.

I'm embarrassed.

I was blind and got confused.

All is fine now.


I had seen a video where a guy was demonstrating his settings for the game, and it *looked* like he was applying a speedhack of EE +2 on a PC weaker than mine, but it was an older version of pcsx2 with a different layout. It was actually EE -2. If I do that, I get good results.

But I will disable mtvu, thanks.

Try overclocking a bit too. This game will run better if you don't have to adjust the EE slider at all.
Reply




Users browsing this thread: 1 Guest(s)