Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WHY do MGS2 cutscenes lag when game play is fine?
#1
Hi there

I am just extremely curious as to why the cutscenes in Metal Gear Solid 2 consistently lag, while in-game action with no pre-rendering is completely smooth and fine?

There must be a specific config/setting that can allow the cutscenes to run without slow-down (extreme slow motion and audio-stutter)....

I've been trying to get the MGS2 Substance PC Port to run as an alternative but that is an absolute nightmare too, cutscenes are fine, but I run into all sorts of texture issues, and when applying the fixes (of which there are about 5 different stages of patches and file to apply) I just get an error which crashes the game...

I've got the game and a PS2 still in use, but I'd love to play it on my computer with better resolution than the 480p native of the PS2..


Such a shame, at this stage my only real solution is to buy a PS3 and the HD/Legacy Collection!

Someone out there must have a way to run MGS2 on PCSX2 without the cutscene slowdown?


Any help would be greatly appreciated. 

Many thanks!

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#3
(06-13-2016, 05:49 PM)refraction Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

Hi there, it's not really "my" problem, as there are many people reporting the exact same issue.


Otherwise...

Intel i7 920 (overclocked to 3.3ghz, 8 Virtual Cores)
ATI Radeon HD 7870 (2GB, OC GPU Clock to 1060MHZ, 1240 Memory Clock)
Windows 7 64bit Ultimate - SP1

PCSX2 1.21 (should still be latest I believe)

4x Native Resolution (Even 2x has the same issue, only game affected, gameplay is fine, ONLY cutscenes have slowdown)

MGS2 from ISO and Double Layer DVD (Original Copy)


Anyway, the information I provided has no bearing on the problem, as people with both more powerful and less powerful computers run into the same issue.

What I am wondering is the possible explanation as to "why" the cutscenes are causing slowdown when gameplay does not?


Thanks
#4
1.4.0 is the latest version: http://pcsx2.net/download/releases/windows.html
And you can also try the dev builds as it could be faster: http://buildbot.orphis.net/pcsx2/index.php

Can you post your other settings too?
Your CPU is a little outdated, do you have MTVU hack enabled to get the most out of it?
And are you running Direct3D 9 or 11?

Also try the Video(GS) Plugin Settings options like "Allow 8-bit textures", and do try a lower native resolution, 4x is really at the limits of your hardware.
#5
(06-13-2016, 08:15 PM)FlatOut Wrote: 1.4.0 is the latest version: http://pcsx2.net/download/releases/windows.html
And you can also try the dev builds as it could be faster: http://buildbot.orphis.net/pcsx2/index.php

Can you post your other settings too?
Your CPU is a little outdated, do you have MTVU hack enabled to get the most out of it?
And are you running Direct3D 9 or 11?

Also try the Video(GS) Plugin Settings options like "Allow 8-bit textures", and do try a lower native resolution, 4x is really at the limits of your hardware.

My CPU may be old, but it actually performs better than peoples current gen i5 overclocked to 4ghz... yet I'm only on 3.3ghz (thanks to the great virtual threads)
Yes I have MTVU, all the 4 main speedhacks are activated (for most games), cyclerate and cycle stealing do not change the affect of the cutscenes.


Like I have been saying (I hate to re-iterate but you guys seem to be missing the point entirely)

The CUTSCENES are lagging, gameplay is absolutely smooth and fine, I am wondering, WHY cutscenes are lagging, when the more hardware consumptive processes like real-time gameplay are not suffering from any frame rate drop?

So as I say, it is not an issue of not enough speed or power, it is an issue that something to do with the cutscenes is causing extreme performance drop, this is not a hardware issue or anything of the like, this is some sort of error in the code or emulation engine.

Edit: Also as I said earlier I tried 2x Native Resolution with the exact same results, smooth gameplay, but huge frame drop during cutscenes)

Thanks for posting and alerting me to the latest build and dev builds, I will certainly try the newest version also!
#6
(06-13-2016, 08:35 PM)SYNCHRONIC Wrote: My CPU may be old, but it actually performs better than peoples current gen i5 overclocked to 4ghz... yet I'm only on 3.3ghz (thanks to the great virtual threads)

Not in PCSX2 it wont Wink HT does nothing for PCSX2, its all about single thread performance. Although that cpu isn't terrible, you will probably have a much nicer experience at 3.6 or 3.8 (i used to own an i7 920 @ 3.8Ghz)
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#7
That may well be, but my friend owns a current gen i5 which ias at 4ghz and he has the exact same issue... so CPU performance is not a factor in the running of the cutscenes in MGS2 at full speed... unless it is necessary for a 5ghz nitrogen cooled CPU to run these pre-rendered cutscenes at full speed you think?

Any hints as to the issue at hand?
#8
(06-13-2016, 08:35 PM)SYNCHRONIC Wrote: My CPU may be old, but it actually performs better than peoples current gen i5 overclocked to 4ghz... yet I'm only on 3.3ghz (thanks to the great virtual threads)
Yes I have MTVU, all the 4 main speedhacks are activated (for most games), cyclerate and cycle stealing do not change the affect of the cutscenes.


Like I have been saying (I hate to re-iterate but you guys seem to be missing the point entirely)

The CUTSCENES are lagging, gameplay is absolutely smooth and fine, I am wondering, WHY cutscenes are lagging, when the more hardware consumptive processes like real-time gameplay are not suffering from any frame rate drop?

So as I say, it is not an issue of not enough speed or power, it is an issue that something to do with the cutscenes is causing extreme performance drop, this is not a hardware issue or anything of the like, this is some sort of error in the code or emulation engine.

Edit: Also as I said earlier I tried 2x Native Resolution with the exact same results, smooth gameplay, but huge frame drop during cutscenes)

Thanks for posting and alerting me to the latest build and dev builds, I will certainly try the newest version also!
I have the game and an i5 and there is zero lag in the cutscenes. The cutscenes are more demanding, some specific scenes in PS2 games call on things that are just more demanding to emulate than the rest of the game. Like refraction said, your i7 just isn't as good for PCSX2 as it is for PC games.

@newer post: Your friend(and you) might have settings that make things worse. That's why we asked you to post your settings. Wink
#9
Can you show us your GSDX settings please?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#10
(06-13-2016, 09:27 PM)FlatOut Wrote: I have the game and an i5 and there is zero lag in the cutscenes. The cutscenes are more demanding, some specific scenes in PS2 games call on things that are just more demanding to emulate than the rest of the game. Like refraction said, your i7 just isn't as good for PCSX2 as it is for PC games.

@newer post: Your friend(and you) might have settings that make things worse. That's why we asked you to post your settings. Wink


You seriously don't have any frame rate drop in the cutscenes for Metal Gear Solid 2?

Any chance you could please share YOUR settings with me?

I'd be incredibly grateful....



Here are my settings anyway, I've tried tweaking, but these are the ones that are compatible for most games.

[Image: 2eb4i9z.png]

* Link to full size image - http://i67.tinypic.com/2eb4i9z.png




Users browsing this thread: 1 Guest(s)