Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird SoTC issue.
#1
First of all please do not ban me, again. I don't have access to my old forum account due to lost password and e-mail.

Well I was looking forward to play Shadow of the Colossus after receiving my new laptop. Turns out it runs better than I had expected but it sill has some issues. The game runs amazingly smooth although it seems slower than on the Playstation 2. However the performance almost doesn't change no matter what resolution is in use. It's not until Full HD that it starts dropping heavily. If my system is capable of running SoTC on 1600x900 with 50 FPS, shouldn't the game the frame rate increase in lower resolutions? Don't worry I disabled the frame-limiting. Of course the game goes up to 70 frames when I am looking at the sky or walls but demanding scenes have almost the exact same frame rate regardless of the resolution. How is that even possible?

Can someone tell without spoiling - Never got the chance to beat the game and don't want to start progressing on PCSX2 until I optimize my settings - if the other boss battles later in the game are much more demanding in terms of performance than the first one?

Intel i7-4700MQ @ 2.40 GHz (3.40 GHz Turbo Boost)
Nvidia GT 750m 2GB GDDR5 (70MHz overlocked)
4GB DDR3 @ 1660 MHz
Windows 8.1

Direct3D 11 (Hardware)
Texture Filtering (Full)
Anistropic Filtering
Allow 8-Bit Textures

Clamping Mode: None
mVU Flag Hack: On
EE Cyclerate: 3
Reply

Sponsored links

#2
Quote:However, if my system is capable of running the game at 50 FPS stable up to 3x resolution than shouldn't it run much smoother in lower resolutions?
depends on which part of the game. some are more demanding than others.
As a side note, increasing internal res will strain your GPU. if your cpu is struggling in some places, increasing or decreasing internal res won't change anything.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Shadow of Colossus is as far as I know one of the most difficult PS2 games to emulate properly.

But the thing is, what are causing "false" FPS readings on your case are the Speed Hacks. Using extremely high values on EE and VU Cyclerates causes games to show false FPS readings, so, while it may show on your screen 60 FPS, that's not the actual frames per second that game's running at.

Try deactivating the EE and VU Speed Hacks. Yes, you'll loose probably lots of FPS, but at least you'll know how much that game's running at.

And yes, welcome to the team, my i7 3920XM (which is slightly more powerful than your 4700QM and even has Hyperthreading disabled) isn't able to properly emulate that game too, so, there's not much that can be done here unfortunately.
Reply
#4
Keep EE cycle to 0 for this game, but you can set VU cycle stealing to 2 with almost no side effects, and that will be the best way to play the game with your specs
[Image: newsig.jpg]
Reply
#5
First activate all the recommanded Speddhacks set resolution to 2x Native, turn off the EE Cycle and set VU Cycle to 1 or 2.
If its still to slow try to play around with the sliders a bit (e.g. EE:0, VU:3 or EE:1, VU:2) but never set them both to 3,3.
MTVU is usually slower in this game but you can give it a try, same goes for "Allow 8-Bit Textures"

(06-28-2014, 10:05 AM)VanguardWolf Wrote: Can someone tell without spoiling - Never got the chance to beat the game and don't want to start progressing on PCSX2 until I optimize my settings - if the other boss battles later in the game are much more demanding in terms of performance than the first one?

Yes some of the later fights are more demanding but not that much (5-10 FPS slower maybe)
Reply
#6
(06-28-2014, 10:51 AM)Bositman Wrote: Keep EE cycle to 0 for this game, but you can set VU cycle stealing to 2 with almost no side effects, and that will be the best way to play the game with your specs
Thanks but I've already tried using VU Cycle and the game becomes unplayable or should I rather say enjoyable. The animations become choppy, the game itself runs very unstable and the input delay is annoyingly high. Meanwhile with EE on 3 it seems slower than originally intended but is almost smooth as butter (most of the time).

(06-28-2014, 11:05 AM)Grove4L Wrote: First activate all the recommanded Speddhacks set resolution to 2x Native, turn off the EE Cycle and set VU Cycle to 1 or 2.
If its still to slow try to play around with the sliders a bit (e.g. EE:0, VU:3 or EE:1, VU:2) but never set them both to 3,3.
MTVU is usually slower in this game but you can give it a try, same goes for "Allow 8-Bit Textures"


Yes some of the later fights are more demanding but not that much (5-10 FPS slower maybe)
(06-28-2014, 10:39 AM)wetto Wrote: Shadow of Colossus is as far as I know one of the most difficult PS2 games to emulate properly.

But the thing is, what are causing "false" FPS readings on your case are the Speed Hacks. Using extremely high values on EE and VU Cyclerates causes games to show false FPS readings, so, while it may show on your screen 60 FPS, that's not the actual frames per second that game's running at.

Try deactivating the EE and VU Speed Hacks. Yes, you'll loose probably lots of FPS, but at least you'll know how much that game's running at.

And yes, welcome to the team, my i7 3920XM (which is slightly more powerful than your 4700QM and even has Hyperthreading disabled) isn't able to properly emulate that game too, so, there's not much that can be done here unfortunately.
Thanks to both of you but the thing is, it's running for me. 50 frames are enough on my PAL copy of the game. I was assuming that lower resolution would mean higher FPS/smoother gameplay and was wondering why it wasn't the case. The game was constantly running between 45 and 55 FPS regardless of the internal resolution but seems like jesalvein already answered my question.


(06-28-2014, 10:22 AM)jesalvein Wrote: As a side note, increasing internal res will strain your GPU. if your cpu is struggling in some places, increasing or decreasing internal res won't change anything.
Well that explains everything. EE is constantly at 100% while GS rarely exceeds 50%.
Reply
#7
For me the ideal settings are

Set VU Cycle Stealing to 1 or 2, it looks choppy when he runs, but he does without the hack as well.
Turn MTVU on, this should give you a 30% speed boost roughly
Turn on all the recommended speedhacks (INTC Spin detection, Wait loop detection, MVU Flag hack), this should give you about 3-4 FPS
You could also enable the EE Timing Fix under Game Fixes for an additional 1-3 FPS
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#8
Uh I get a slowdown with MTVU and SotC....
[Image: newsig.jpg]
Reply
#9
I gain about 20FPS with it Tongue

Don't worry I tested it before I recommended it.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
SOTC is on my slowdown list for MTVU. It slows down for me, and jesalvein was the one who told me about it too. Interesting.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply




Users browsing this thread: 1 Guest(s)