Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird colors, strange cracking noises and a lagging screen
#1
Hej guys,

I've been able to play KH2, FFX without any problems 'till now, well there a bit of weird camera angles and stuff but nothing serious... but now I really want to play FFX-2, FFXII and KH.

PROBLEM 1 : The problem with FFX-2 and FFXII is , that they LAG A LOT !!! .. I haven't been able to get through the first cutscene of FFX-2 because it was lagging too much.. so i don't know how the game itself is doing.., the same problem for FFXII.. I've been able to skip the cutscene and it seems to work a bit.. but it's so slow..

PROBLEM : and it doesn't do what I do with the controller... It's completely messed up :/

All the games are my own discs.. And FFX probably has the most scratches, but that's the one that works the best...So I made iso files of them... Tongue2

PROBLEM 2: Another problem is that KH colors are really weird and messed up Sad ... (+ cracking sound in FFX)

Hope you can help me !
Happy Gaming Holidays !

I'm using a standard macbook pro 13" , with a 2.4 GHz intel core duo processor , and 4GB 1067 MHz DDR3 Memory .... grpahic card : NVIDIA GeForce 320M ... also i'm using the latest pcsx2 mac version... I don't think i'm using any non default settings... :/ so yeah... tthat's all i guess ! thanks !! Smile
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
EDITED ! Hop you can help me better now !
Reply
#4
i have the same model as you. I wrote a thread a while back about optimizing your computer for running FFXII.

Hopefully this helps

http://forums.pcsx2.net/Thread-FFXII-Bes...-Users-FPS

Dunno about your other issues though.
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

Reply
#5
So mubbsy, I used every config as you have, but it's still utterly slow Sad and the menu , is so weird , all of those vertical lines in the screen :s like there is a black stripe filter before it... really weird :/
Reply
#6
hmm never seen that. have you also tried making sure all other programs are closed to enable all your system resources and making sure you are plugged in while playing? i found those 2 to help a bit. wonder if i have a different OSX version than you do. I recently upgraded to 10.6.8 from 10.6.7 but haven't tried pcsx2 since the update. which version are you running??
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

Reply
#7
The newest one 10.6.8, but i've been playing pcsx2 mac for almost a year, probably still 10.6.7 at that time.. (Snow Leopard)

really weird.. first thing i thought is that it probably was my disc that was scratched ,but i have it with both FFX-2 and FFXII , but not with FFX (and that's the oldest one !) so well that's not it :/ and also ffx-2 works... but it's a bit too fast sometimes... i don't know anything about this stuff :s so I just used your CPU configs from the last pictures you posted from FFXII xs (with costum FPS limit : 60 ,,, etc etc

thanks for helping me already ! Laugh
Reply
#8
SORRY for doubleposting ! but i can't attach a new item, so this is how FFX-2 looks , and FFXII looks the same...


.zip   Screen shot 2012-01-03 at 19.39.06.zip (Size: 1.003,1 KB / Downloads: 282)


.zip   Screen shot 2012-01-03 at 19.39.23.zip (Size: 878,15 KB / Downloads: 119)


had to compress the images because they told me the file size was too big (max 500kb)
Reply
#9
hmm, well as far as ffx-2 running too fast you can toggle the framelimiter with the tab button to enable the custom fps settings.
Not really sure why you are getting that weird effect though. Its gotta be something with the video plugin but im not sure at all. maybe a different resolution size or something could help cus sometimes my edges look like that if i try to maximize it and stuff.
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

Reply
#10
is it possible if you could send me your pcsx2 app with all your plugins , so i have everythign the same as you ?

+ i tried to change the screen resolut, and it didn't work Sad + i don't get what you mean with "toggle the framelimiter" xs

thanks for your help !
Reply




Users browsing this thread: 1 Guest(s)