Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird problem with PCSX2
#1
I have a very strange problem when running the emulator, sometimes the app detects erroneously that my processor is at 2.233 ghz (the FPS drops from 60 to 45 in most of the games I play), when in reality is clocked at 2.833 ghz. I don't know what is causing this, I have the CPU at its stock speed, also have the pre-requisites of the emu (visual 2010 redistributable SP1 x86).

For a month I have struggled with this weird bug, until today, without doing anything I tried again and it correctly detected the clock speed. Btw I didn't installed anything, its just happened this at random and I don't now how much time it will last.

Any ideas or suggestions?

My specs are
Q9550 at 2.83 Ghz
Intel DP45SG Motherboard
Asus GeForce 9600 GT
2 GB of Ram and Windows 7 Ultimate SP1

I am using PCSX2 1.0.0 rev 5350
Reply

Sponsored links

#2
did you set your power plan to high performance ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
The power scheme is configured for "Office or Desktop"
also the turn off HD, monitor and inactivity is configured to "Never"
Reply
#4
Select "advanced" and choose "high performance"
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
May want to head into BIOS and shut off Speedstepping as well. If it isn't already.
Reply
#6
um.. checked my guide yet?
Reply
#7
OK I will follow the advices, so this has nothing to do with the emu? its my system who is underclocking when idle or something? thanks for the responses

@Saiki
The problem is not the low FPS, they are steady 60 when the emu detects my 2.83 GHz processor correctly
Reply
#8
OK the glitch happened again, today I started the emu normally and now is showing that the processor is clocked at 2.233 Ghz, I disable "Intel Enhancent Speedstepping" in the BIOS, Its already at "High Performance" in the Energy Plans Configurations, I don't know what to do. Is there a way to force the emu to read 2.83 Ghz?
Reply
#9
yes, power options
90% - 99%
Reply
#10
is the game starting at 60 fps or at 45 fps?

if it started at 45 fps then there is a problem

if it started at 60 fps, stayed on 60 fps for some time then dropped to 45 fps then it's ok. it could be a demanding game. is it going back to 60 fps after it drops or it stays 45 fps?

check your graphic card settings. is pcsx2 using the geforce card to the full extent or it is in power saving mode?

mess around in the graphic plug in settings. you should use directx10 or directx11 hardware. try ticking the native checkbox. also turn on speedhacks
Reply




Users browsing this thread: 1 Guest(s)