Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
What am I doing wrong? (framerate problems)
#1
Well here's the thing! I've tried and tried and tried to get this thing working well, and no matter how many tutorials I read and settings I change, my PS2 games won't run smoothly enough. I don't get it. Sad

My PC specs are:

Intel Q8200
Nvidia Geforce 9800GT
4GB RAM
Windows 7 x64

I know it's not a beast anymore, but I meet (if not surpass) the recommended requirements for playing games on PCSX2 (according to the sticky thread here) and I've read posts from people in the past playing games fairly smoothly that play really badly for me, when they have worse systems than I do.

I have tested all my PS2 games, which amounts to 42 games (I was really bored one afternoon) and tried adjusting the settings for all of them and reading the forum for tips on how to get particular games running well, and nothing seems to work. Most of my games are listed as 'Playable' on the compatibility listings, but they are not at all playable for me. I found two games that run okay and are fairly playable (Okami, and Resident Evil: Code Veronica) but all the rest play horribly with an average of 20fps or sometimes less.

Frame-skipping and speed hacks never help, they sometimes make the framerate better but then the gameplay gets very jerky and choppy.
Reply

Sponsored links

#2
It would help if you show us screenshots of your pcsx2 running games when they're slow and your settings.

The recommended CPU for PCSX2 is a Core 2 @3.2GHz, your Q8200 is barely 2.3GHz so you don't surpass them, you should get a lot more than 20fps though.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
(06-09-2010, 01:11 PM)Shadow Lady Wrote: It would help if you show us screenshots of your pcsx2 running games when they're slow and your settings.

The recommended CPU for PCSX2 is a Core 2 @3.2GHz, your Q8200 is barely 2.3GHz so you don't surpass them, you should get a lot more than 20fps though.

Yes it's a 2.3Ghz but its a quad-core processor so shouldn't that be okay?

It says on one of the sticky threads here:

Will work at a reasonably playable speed (this does not mean full speed):

Intel Core 2 Duo (and laptop Core Duo equivalent)
Intel Core 2 Quad


and mine is a Core 2 Quad I believe?

I can definately post some screenshots of the games being slow but how will that help you diagnose my problem?? Or am I confused as to what you meant there?... As for settings I just leave everything on default at first and then try to change things accordingly to achieve a decent frame rate, I have tried most variations of settings and nothing seems to work. It's difficult for me to show you any specific settings because I keep trying to change them all the time.

Thanks for taking the time out to help me. Smile
Reply
#4
PCSX2 only uses 2 cores and likes higher clocks than a higher number of cores. A higher clocked dualcore> low clocked quad in PCSX2.

BTW what version are you using? The latest and most compatible is 0.9.7 3113.
My PS2 Resurrected:
AMD Phenom II x4 oc 3.4ghz
GTX 560 1gb
Western Digital 300gb hdd
4gb ddr800 kingston ram
Asrock N68-S Motherboard
Reply
#5
(06-09-2010, 01:28 PM)Mister Vain Wrote: Yes it's a 2.3Ghz but its a quad-core processor so shouldn't that be okay?

It says on one of the sticky threads here:

Will work at a reasonably playable speed (this does not mean full speed):

Intel Core 2 Duo (and laptop Core Duo equivalent)
Intel Core 2 Quad


and mine is a Core 2 Quad I believe?

You're obviously ignoring the "this does not mean full speed" part Tongue

jadariin explained already but people usually just mistakes a quad core being twice as good as a dual-core or four times a single core which is not the case.


Quote:I can definately post some screenshots of the games being slow but how will that help you diagnose my problem?? Or am I confused as to what you meant there?...

Based on the info displayed in the PCSX2 console and game window while playing we may be able to see something else. Also you say you're using default settings but it would be best if you show us what you're using anyway and we can help more based on that which you may have.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
Well here's some Shadow of the Colossus action

[Image: pcsx21.th.jpg]

[Image: pcsx22.th.jpg]

[Image: pcsx23.th.jpg]

This is without speedhacks enabled, if I turn all speedhacks on I get 60fps but its unplayable thanks to all the extreme frame-skipping, so I can't win either way. Variations on different speedhack options don't help me either, enabling even a single speed hack usually makes games really unplayable.

Here are my GDSX settings.. All default.. If things aren't working right I adjust everything accordingly (though I never get anywhere)

[Image: gsdx9.jpg]

And SPU settings, again all default.. I rarely adjust these.

[Image: spu2.jpg]

All the complicated CPU settings I leave at default too at first except as a last resort (still rarely makes a difference) and Speedhacks & Frameskipping I leave turned OFF unless nothing else works (and again, it doesn't help give me a playable experience)

[Image: cpulz.jpg]

I am using the newest beta of PCSX2 at the moment but I have used older versions before, including 0.9.6 and 0.9.5, and it's all the same.

All of the above applies to all games I have tried, not just SOTC. Nothing gets above 30fps without speedhacks (apart from very brief periods of time), except for those two games I mentioned in my first post, and most games average about 20fps
Reply
#7
Shadow of the colossus is a very demanding game on PCSX2 and in that case the low speed of your CPU isn't gonna help much so the ~20fps is normal without speedhacks or DX10/11 enabled.

Start by switching the renderer in GSdx to Direct3D10/11 (Hardware), then change the VUs to superVU and maybe the clamping modes to 'none'. In speedhacks the recommended ones shouldn't cause any skipping and the one that should help a lot is setting the "VU cycle Stealing" to Mild without much of a skipping problem. Shouldn't need to tick "native" in GSdx.

You mention this happens on all games so you should check if your CPU is running at normal speeds while running the emulator with an app like CPU-Z or coretemp.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#8
using MicroVU seems faster for me, but here's a tip: I have EE1.5 (setting 2) and IOP x2 on, use VU stealing if I need it, but typically don't. won't be full fps though, but you can probably get close.

also sent clamping modes to NONE, this helps speed too.
Reply
#9
2.3 Ghz is too slow. You have to speed hack. Just don't use Frameskipping with VuSteal and it should work atleast alil better.

I'd like to check SOTC out myself. Somebody got a link for a download?

Just kidding Laugh ..
Reply
#10
Dx10/11 should be used in Gsdx renderer as Shadow Lady said but remember 2.3Ghz will NOT guarantee full speed in most games & U will have to use speedhacks IF the games you are trying to run are demanding
Intel E5700 @3.0Ghz,
Xfx Radeon 5670 1Gb,
4Gb DDR3 Ram,
Microsoft Windows7 Ultimate x86
Reply




Users browsing this thread: 1 Guest(s)