Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Which settings should I change?
#1
Hello!

First, I'm very, very sorry for posting the I-don't-know-how-maniest
"Oh crap PCSX2 runs slow! Ohmy" thread, but I don't know who else to turn to. I've got PCSX2 to work, and - being a hardware noob - decided to keep all default settings in place. Then, I put some default settings in place for left pad and d-pad, and the basic buttons using the mouse only. I made an ISO of the game of my choice (from the original DVD): 24 The Game and started it. The menu ran smoothly, on a fps behind 50 and 60. Of course, the menu fps doesn't mean anything, so a launched the intro cutscene. Still, fps between 50 and 60. Then - to my amazement - the fps dropped from 50 to 15. I quit the game and put on speedhacks, but did not change any of speedhacks settings. These are my specs:

Computer: MEDIONPC, model MS-7728
OS: Windows 7 Home Premium 64 Bits
Processor: Intel Core i7-2600 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
Memory 8192MB RAM
DirectX: DirectX 11
Videochipthingy (don't know the correct English word, I'm from Holland): NVIDIA GeForce GTX 560

According to the top of the page, the RAM and processor are high above the minimum settings, but the video card is not listed. Still, I can run the newest games (Deus EX: Human Revolution, for example) on max settings. What do you guys think? Should I chage specific Speedhack settings? Or should I change the settings that I kept on default at the first startup?
Reply

Sponsored links

#2
Try changing the Gsdx plugin settings (Options > Video > Plugin Settings) and make sure you get the latest PCSX2 1.0 and the best/stable plugins.

First things first, you should be able to upscale games to at least x3 (note that being to run good PC games has nothing to do with PS2 emulation). Almost forgot, set the Renderer to D3D11 (Hardware) because it may run better with your Graphics Card. Now, before enhancing the graphics further we need to make sure that the game even runs properly...

So next enable the MTVU speedhack which is in the core settings under "speedhacks". Then try running the game.

STILL SLOW? Enable/tick all the recommended speedhacks. Run it again, and if you still have slowdown, mess around with the EE/VU Cycle sliders.

RUNNING NORMALLY NOW? You could then start enhancing the looks by changing the internal resolution (or in easier terms, upscaling the game) from the GS Plugin settings. Enable Texture Filtering and 8 bit textures if your game runs smoothly. Finally try toggling/enabling Dynamic Vsync frome the core Window settings.
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#3
The FPS is absolutely perfect now, the VU bar did the trick. I'm now messing around to make the graphics better, but thank you in advance!
Reply
#4
Aaaaand... There's the next problem. Only half the EE is used and the fps is 50. THe sound a fluent and perfect, but the movement is some sort of chopped op in very shocky animation. Still, 90% of the graphic stuff is not used with an average of 9% being used. Which graphic detail should I change?
Reply
#5
Just try upscaling a bit and see if you get frame drops (I.E start going x2, x3, x4, etc....) find which suits the game best, since different games may need different settings. The EE 5 shows how much CPU power is used. it dropped down because you enabled the MTVU hack which makes use of processsors with more than 2 cores, which actually makes most games run better (and your PC less hot). Enable texture filtering and 8-bit textures in the GS olugin settings, then tick Dynamic Vsync on the core window settings.

50fps? Is it a PAL game? PAL games are locked at 50fps.

Shocky... you mean the animation stutters? Did you enable/tick all the speedhacks? (except fast CDVD, which I don't recommend using). Maybe try changing the EE speedhack to 1 or 2. The thing is, not every game out there is emulated to perfection, so it's not always because of someone's PC specs.
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#6
try dropping some speedhacks, one of the cycle stealing often causes fake FPS (so its still dodgy whislt reporting the correct FPS)

also slightly off topic, which games have problems with the CD fast access.... ive never had a problem
[Main Computer] - CPU: I7 950 @ 3.2Ghz | GPU: Twin Nvidea GTS 450's SLI'd | RAM: 8GB DDR3 - 1600MHz | OS: Windows 7 Ultimate x64 | EMU: PCSX2 v1.0 | GS: GSdx32-SSE4 | SPU2: SPU2-X | PAD LilyPad | CDVD ****
Reply
#7
fast CDVD access IIRC is similar to using a HDD in fat PS2s (HDloader). There are some games that can benefit the fast loading, but there are some that may not run or crash with it. Idk which but Pcsx2 tells me to check games compatible with HDLoader.

I just don't recommend it just in case of stumbling into a game that can't use it. Besides, the normal loading is good as it is.
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#8
I've fixed it myself. I used a preset that was pretty slow, but with fluent animation and then use the turbo function to make it faster again. Surprised that it worked, I just did something random Tongue

@fake fps: I thought about that too (and read about it, it should be the second slider that causes is), but all the sound and movement speed was fluent, only the moment animations were choppy.
Reply
#9
Just be reminded that PAL games are 50fps. So if you're doing smooth 60fps, it means that the game is running faster than it should be.
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply




Users browsing this thread: 1 Guest(s)