Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Which version for Klonoa 2?
#1
So I tried the latest SVN and .98 and Klonoa 2 is full of graphical artifacts, as well as missing sounds.


I saw here that he used http://wiki.pcsx2.net/index.php?title=Kl...tea's_Veil svn r3878
and while this version does not have as many apparent artifacts in software mode, the sound effects do not play. The music however does.

Would appreciate if anyone who has this game working to post their settings and revision and all that good stuff.

Also is hardware rendering out of the question for rendering at 1920x1080 or something? Because hardware doesn't seem to play so nice. Also progressive scan would be nice...

But the main issue is the sound... though it's kinda sad how one of the best ps2 games doesn't work 100% ;'(
(Graphical artifacts on revision 5336 include missing floor in the intro scene, and other anomolies like the water in the map menu to appear as a pixelated mess)
Reply

Sponsored links

#2
Sadly i've also wanted to play this game for a long time, and while graphical garbage isn't something that is seen often (only when scaling is used), the sound can still be highly problematic. Most often, sounds are not played at all and it cuts out, and usually there's a constant range of high pitched sounds that just won't go away regardless.
Reply
#3
Yeah I just played the first level the sound wasn't playing the effects and I did hear the random screeching as well. I am kind of surprised the game is still broken considering how old r3878 is, a real shame tbh.
Reply
#4
(07-11-2012, 11:04 PM)jigglywiggly Wrote: Yeah I just played the first level the sound wasn't playing the effects and I did hear the random screeching as well. I am kind of surprised the game is still broken considering how old r3878 is, a real shame tbh.

And it really brings back memories from the original.. what a sad ending it had D;
Reply
#5
Hehe, yeah def. Though I actually played the 2nd game first 6 months ago and beat it like a month or two ago(I played it over a course of like forever, didn't want to rush through it at all, and since I obviously forgot some of the game it would be great to replay it). Then beat the first game (wii remake in phantomile language ofc) 2 weeks ago. I actually think that's the proper way to play it since you can appreciate the story more in the first one when playing.

Though I could obviously play on the PS2 again, I'd prefer playing on the PC since I tend to pay more attention then.
But mainly it's because a few of my friends want to play Klonoa 2 after I nagged them to go play it... but they are too lazy to get their PS2'z out(I am a pc gamer, and so are they), so it would be great if they could just play on pc.
Reply
#6
Thanks for reminding me about this game. I'm not seeing or hearing any of these problems in the JP version. No missing sound effects or graphics, water looks fine, etc. I'm using r5178 build with a newer gsdx and mostly default settings (only changed EE clamping to Full). It is the Japanese original though so that might be part of it
Reply
#7
Just tried your svn version, still same problem. Maybe the Japanese version just works, which I find kind of odd.
I did set clamp mode to full, though what renderer are you using? I am using dx9 software, since it produces the least errors.

Hunting the Japanese version game isn't going to be easy either.
In the Japanese version are they speaking in phantomile or Japanese?
Reply
#8
I generally use dx11 hardware. There are no major glitches with klonoa 2 when I use it, although the cel shading looks weird unless you play at really hi-res


[attachment=38846] [attachment=38847] [attachment=38848]
soft > 2x res > 4x res

But honestly I've only played the first level on pcsx2, so I can't comment if it gets messed up later. I can only say there's no missing ground, messed up water, and everything sounds like just I remember it (but it's been like 10 years lol)

And they all speak phantomile in the jp ver, but text is jp obviously
Reply
#9
Oops, forgot about the text being in Japanese, now that would be a problem.
Reply
#10
so i tried again way later now
hmm anyone else try this? .9.6 seems to work the best, but it isn't good either. It probably has that bug later in the game where it freezes. And objects are misplaced even with clamp set to extra
Reply




Users browsing this thread: 2 Guest(s)