Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Why is a 2d game's Snapshot sharper than Actually playing it on the Emulator?
#1
Smile 
I know this sounds weird because a Snapshot should be the exact same Quality as the one on the Actual Emulator.

Okay, I made a snapshot for a 2d game(Growlanser 2) and tried to compare that snapshot with the Emulator on the Screen. For some reason, the snapshot version is sharper.

Down below you will see 2 pictures.

THE TOP is the SNAPSHOT.

THE BOTTOM is the ACTUAL EMULATOR which I made the Snapshot from (I used the PRINT SCREEN KEY to make the picture).


This is the PCSX2 Snapshot

.bmp   PCSX2 Snapshot.bmp (Size: 330,26 KB / Downloads: 272)


This is the ACTUAL EMULATOR which I made the Snapshot from
   


As you can see the Snapshot is sharper than the Actual Emulator.

In fact, try it yourself for any 2d game and you will see what I mean. Do the same thing I did and you will see.

I am not sure why is it like that.
Is there any way for the Actual Emulator to be as sharp as the Snapshot?










Reply

Sponsored links

#2
The snapshot is sharper because it is an exact copy of what is inside the PS2/GS framebuffer; you're getting the raw pixels being output. One the other hand, when pcsx2 is displaying the image in its window, the frame is being scaled to fit the window, thus causing some blurring.

With that said, I'm not sure if pcsx2 can run its window in a manner where the pixels are displayed one-to-one.
Reply
#3
Is there any way for the pcsx2 to run its window in a manner where the pixels are displayed one-to-one? I want to get rid of that blurring so that it will look as sharp as the snapshot. Shadow Lady, if you are there, do you know if there is some way to make it look as sharp as the snapshot?
Reply
#4
I think I've figured it out... (based on what I could see, pcsx2 or gsdx is cropping then scaling the image to the window... wtf, right?)

So, for that game (which runs at a native resolution of 640x448)

In Emulation Settings -> GS Window
-set the Aspect Ratio to Fit to Window/Screen
-set Custom Window Size: 636 x 444


screenshot of settings...
   
Reply
#5
set the window dimensions exactly to the native screen resolution and disable any stretching. disable Tri/bilinear filtering as well

or you could just use the internal scaling to hardware upscale the output image.
Reply
#6
You are right Patrickdinh! It works! The Blur is gone! Thank You! We need to put this information in the FAQ. One last question... does the window size have to be 636x444? Could it be 576x403?
Reply
#7
(04-04-2011, 04:12 AM)sentinel42 Wrote: You are right Patrickdinh! It works! The Blur is gone! Thank You! We need to put this information in the FAQ. One last question... does the window size have to be 636x444? Could it be 576x403?

It depends on the native resolution of your game (your game was running at 640x448). All I did was subtract 4 from the width and height of that resolution.
Reply
#8
Oh I see. So what it if I were to subtract 8 instead of 4 for this game. Will the blur disappear?
Reply
#9
(04-04-2011, 04:22 AM)sentinel42 Wrote: Oh I see. So what it if I were to subtract 8 instead of 4 for this game. Will the blur be disappear?

Most likely, the blur will show up (since the window size wasn't set up with the right dimensions).
Reply
#10
Okay then. So the game, Tales of the Abyss runs at a native resolution of 512x447, so I just need to subtract by 4 to get rid of the blur?
Reply




Users browsing this thread: 1 Guest(s)