Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Win10 Slow Performance with OpenGL (not gsdx.ini related)
#1
I'm having trouble running anything at all with OpenGL because it runs at exactly half the speed of D3D11 (feels like some sort of framecap?). i can get most of what i want to play working with D3D11 anyway but i figured i'd ask about it here since i also noticed the very same symptom in retroarch and suspect it might be a windows 10/graphics driver issue or some other thing that could interfere.

Specs:
Core i7-5700HQ (2.7ghz)
Geforce GTX 980M (4gb vram) with driver version 358.91 (Latest as of writing)
8Gb ram
Windows 10 64-bit

I've been using multiple versions of 1.3.1 from the GIT download page including the latest one (as of 18/11/2015 at 3:00 pm gmt) and i've got no VU Cycle stealing or EE Cyclerate hacks on and i have tested at native and higher than native in multiple tests. Using the SSE41 version of GSDX 20151118095343. Mostly been testing God Hand and Ys: Ark of Napishtim from both ISO and DVD's though Zombie Hunters 2 also has the same issue when using OGL. I have also tried deleting the gsdx.ini multiple times to make sure no residual errant strings are present like in the other thread i saw relating to windows 10 and slow OGL with no luck.

As i said before though, it also happens somewhat selectively on non demanding systems on Retroarch which is why i suspect it's not the emulator itself but instead something else. Just asking here incase anyone has any possible answer to this. googling about windows 10 and slow OGL performance turned nothing up either so i have waited and researched before posting this.
Reply

Sponsored links

#2
What are the fps/ee/gs readings for OGL and Dx11?
Reply
#3
please provide your GSDX Plugin settings, Thanks. what other applications do you observe a performance impact on Opengl renderer ?

why do you think it's a driver/os issue ? did you try a different driver/os setup ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#4
God Hand D3D11: Spd: 100% (59-60) EE: 40-50% GS: 10-20%
God Hand OGL: Spd: 50% (29-30) EE: 20-30% GS: 90-100%

Not sure how indicative that is of the problem but the only thing that stands out there is lower EE and FAR higher GS usage. but isn't GS handled by my GPU (980M)? which in theory should be more than capable of doing OGL otherwise than what it's showing. this is part of what leads me to believe there's more to it than just "ur hardware sux ;D" if i'm ill informed there then please educate but otherwise i'm not sure what could be causing it.
Reply
#5
well, my question ....

Quote:please provide your GSDX Plugin settings, Thanks. what other applications do you observe a performance impact on Opengl renderer ?

why do you think it's a driver/os issue ? did you try a different driver/os setup ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#6
I did look round for some sort of "template" or something that details exactly what you would need to know and didn't find one so sorry if i missed it.
The main reason i think it's a driver/os issue is because it is also happening in some way in Retroarch with low-demand cores and did so on my previous laptop with NES  cores (which were not demanding at all) on a windows 10 laptop but with AMD graphics instead of nvidia (i53230M, 6gb ram, AMD Radeon HD 7650 for previous laptop)


and as for the GSDX plugins, it seems like not even HW hacks made any difference so i have messed around a lot before deleting gsdx.ini. that being said those numbers i just posted were with these (bar the changeover between D3D11 and OGL) which were almost vanilla due to my having tried deleting gsdx.ini
[Image: azJ65v.png]
Reply
#7
Make sure multithreading is enabled in your nvidia control panel (this is for opengl) and make sure gsdx has your nvidia card selected.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#8
just made sure to check both and retest. if the multithreading you're referring to is "Threaded optimization", then it failed. though switching it on did get it to go to 200% temporarily then forced it back down to 50% as if it was being imposed.
Reply
#9
Did you accidentially forced somewhere the fps? Vsync related settings checked?

Do you see something interesting in gpu-z during emulation with ogl and dx11? Maybe during switching the mt option?
Reply
#10
okay, that vsync suggestion got it going. in the driver it was set to go by the application. switch it off and it's hitting 100%. that still tells me that PCSX2 was telling it to do vsync even though i haven't set vsync in PCSX2 at all. either way, it works.
Reply




Users browsing this thread: 1 Guest(s)