Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windowed has more framerate than Fullscreen
#1
Well, i was playing Soul Calibur 3 on my rig: 
Core i5 4460 3.2-3.4Ghz
8GB DDR3
INTEL HD 4600
It flutuactes through 55-60 fps which is a little strange, but when i put the game on windowed mode it stays at 60 fps, really, on the very click of Alt-Enter the speed varies. 
Anyone knows what it may be?
Reply

Sponsored links

#2
Probably because you only have an onboard graphics card. if you get a proper graphics card it will likely be fine (a half reasonable one anyway, not like a GT 710 or anything..)
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
pcsx2 only uses windowed mode. fullscreen is nothing more then windowed (fullscreen/Boarderless) *correct me i wrong but this is still true?* going fullscreen need more power though

CPU might be fine but iGPU probably not, lower you scale 2x see what happens
Reply
#4
I'm already on native Sad
And the thing is that on fullscreen and windowed the GPU max 82% of use, no more than that.
Reply
#5
that is still quite high, but that figure doesn't show the slowdown caused by hardware, I'm pretty confident the graphics card is the issue.

and yes you are correct tsunami2311 Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
you could try puting MTVU hack on but dont think it will help anyway if the iGPU is cause
Reply
#7
I'm already with the MTVU hack, this is pretty strange and funny at the same time, i mean, it's the same internal resolution.
Reply
#8
The internal resolution is the same but the actual resolution is different unless you set the custom window resolution to be the same as your fullscreen resolution. While the internal resolution (the resolution the virtual PS2 inside your emulator) is handled by the GPU and CPU the screen drawing is probably handled mostly by the GPU alone.

I don't know what version of windows you are running but you might get slightly better framerates by disabling desktop composition (right click the ps2 exe and select properties and it should be under compatibility) and maybe visual themes. If you are fullscreen borderless window then DWM is still running unless it somehow changed in the unknown version of windows you are running.
Reply
#9
I have a similar issue with PPSSPP on my laptop. AKA I can have the internal set to one thing while the window resolution will indeed cuase slowdowns if its to to large.
Reply
#10
I'm on windows 10, so i can't really do that unfortunatly.
And this is happening on dolphin too, while i'm playing Super Mario Galaxy, runs smooth at 60 fps, but when tick the option for fullscreen it goes down to 55fps or less, which is BAD, i don't know why, but it appears that dropped a LOT of frames.

An question to the PCSX2 developers, you guys plan to add Directx 12 support? because it done wonders on Dolphin for me(No more slowdowns on F-Zero GX desert tracks, no more slowdowns on Legend of Zelda: Twilight Princess, and so on..).
Reply




Users browsing this thread: 1 Guest(s)