Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows 10 - "Failed to init XAudio2 engine"
#1
[Bug Report]All Games

#PCSX2 version: v1.3.1-1028-gbfadd88 (latest)
#Emulation options: EE/IOP defaults, VUs defaults
#Plugins Used: GSdx 1.0.1.9 (hardware and software, OpenGL), SPU2-X 2.0.0.4851
#Description: As soon as I try to start emulation, I get this error:

Quote:Failed to init XAudio2 engine. XA2 may not be available on your system. Ensure that you have the latest DirectX runtimes installed, or use DirectX / WaveOut drivers instead. Error Details: (code 0x80040154)

Unknown error code!

Except I do have the DirectX runtimes and XAudio2 dll files installed. I even tried running repair on the 2013 runtimes. I did not get this error when I had Windows 8.1.

[Image: 08i2IJn.png]
[Image: RGWxIsI.png]
Reply

Sponsored links

#2
I would suggest to use portaudio as quick solution.

Still updating dx9.0.c seems reasonable to me.
Reply
#3
I'm unable to "update dx9.0.c" because I'm not on Windows XP.
Reply
#4
Downloading the resist and installing it should be better though.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(08-22-2015, 06:38 PM)jesalvein Wrote: Downloading the resist and installing it should be better though.

https://www.microsoft.com/en-US/download...x?id=34429 This? Because I get blocked on install because I'm not on XP.
Reply
#6
This isn't a bug report as this is the first I've heard of it, so treating as a support issue for now, moving to the appropriate forum.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
Being new disqualifies it as a bug?
Reply
#8
Until it is proven to be a bug, it will not be treated as such, simply because many of us are already on windows 10 and having no issues with XAudio2, you are the only person who is, so it's more likely to be a fault on your computer than a bug in the emulator.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
(08-22-2015, 06:26 PM)tony971 Wrote: I'm unable to "update dx9.0.c" because I'm not on Windows XP.

You need this
http://www.microsoft.com/en-us/download/...px?id=8109
Reply
#10
(08-22-2015, 07:28 PM)vsub Wrote: You need this
http://www.microsoft.com/en-us/download/...px?id=8109

This worked! Thank you so much.
Reply




Users browsing this thread: 1 Guest(s)