Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows 8.1 getting "Need to update Direct X libraries" on install
#1
Trying to run the latest version of PCSX2 (git version) and upon attempting to install it on an i5-4590 PC with Intel HD graphics I get a "You need to update your directX libraries would you like to do that now?" If I click no I get a "failed to load plugin" error. If I click yes it redirects me to a windows 10 upgrade page. Any ideas on why it's doing this or why it redirects me to a windows 10 upgrade page instead of a direct X library?
OS: Windows 10 64 bit
Processor: i7-6700k
GPU: AMD R9 Nano
Ram: 16GB DDR4
Reply

Sponsored links

#2
Try this

http://www.microsoft.com/en-us/download/...px?id=8109
DESKTOP 
i5 4690k @ 4.4 GHz GTX 970 16 GB RAM Windows 10 Pro
LAPTOP
i7 5700HQ GTX 980M 16 GB RAM Windows 10 Home
EQOA Revival Wiki

Reply
#3
That seemed to work thanks
OS: Windows 10 64 bit
Processor: i7-6700k
GPU: AMD R9 Nano
Ram: 16GB DDR4
Reply




Users browsing this thread: 1 Guest(s)