Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Wipeout Pulse slows down in very specific areas
#1
First of all, thanks to all the developers for the emu and the plugins!

System:
E6300 1.86 GHz Sad
8800 GTS 320MB
4 GB
Vista Home Premium


I'm trying to get Wipeout Pulse to run at a reasonable speed, graphics be damned.

It actually runs in realtime most of the time, at 95-105%, until there is a battle happening on screen or when you get near the start line on most tracks for reasons unknown. Then it goes to 55-80%. These numbers may be respectable, but not in a racing game - if your speed keeps changing, it is impossible to drive.

Version: r1888 (Sep 20)

Graphics: GSdx SSSE3 0.1.14
DX10
Res = native (doesn't seem to make much of a difference, I suppose this is GPU limited?)
Interlacing = weave tff sawtooth (this actually made a huge difference; FPS on Gemini Dam during a race went from a consistent unplayable 70% to 100% nearly all the time)
Texture filtering = disabled
This is not the driver that came with the latest beta of PCSX2, but that version (r1873) complained about being unable to find some DX11 file (thrice) and then nothing showed up in the configuration dropdown menu.

Sound: P.E.Op.S. 1.9.0
Disabling the sound in SPU2-X made a big speed difference, but it's hard to play like that. I think this is the fastest sound plugin.
Reverb = 0
Interpolation = 0

CPU:
EERec, VU0Rec, VU1Rec = checked
Both MicroVU options = disabled
MTGS checked
Framerate = limited
In the last release version, it still has frame skip and VU skip. In beta, it only has frame skip. All of them cause the same issue though: instead of skipping frames, the game displays a peculiar rollback effect, like it goes 2 frames forwards and instead of repeating the last frame, it goes one frame backwards again. This is unplayable.

Speed hacks:
EE cycle rate = default
I tried higher cycle rates and did not get decent results. It really did seem to work, especially x3 in the release version, but all it did was speed up the game itself while the FPS remained low. This is even worse to play because now you have to deal with low FPS at full speed.
INTC sync hack = checked
IOP x2 = checked
Idle loop fast-forward = checked
Status flag hack = checked but shouldn't matter
Min/max hack = disabled (even the title screen is scrambled)
VU cycle stealing = maximum (no issues btw)

So far the game runs fine with no visible flaws, except for the speed issue and despite all the hacks.

Is there anything else I can do? Any idea why interlacing makes a difference when internal res doesn't and the system is CPU limited?
Reply

Sponsored links

#2
this issue is mainly beacuse your cpu cant stand it,the most probably fact is that during battles the game asks for more raw power from your cpu,or maybe that game isnt optimized for pcsx2.
Just a little thing that you must know,if you are running the game in native,then the texture filtering option is disabled,so i dont know how you unchecked it hehe.
[Image: 2ymccqu.jpg]
[Image: 17715.png]
Reply
#3
Your Pc is just not cut out for pcsx2, the cpu is way too weak and the graphic card could use a boost too. The only thing I can think of is trying the latest gsdx and playing around more with the speedhacks.

@diegochiha In the Gsdx version the OP has the texture filtering isnt disabled when you use native so thats not in any way out of the ordinary.
Specs:
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Reply
#4
Hmm.
Meh.
Why the graphics card? I see in your sig that you have a card that's just a hair faster than mine and I assume most games work well for you.

And the person above you has a 2.36 GHz cpu, which isn't that much faster, is it?


Maybe I can squeeze a few more fps out of the game though.

- Can I make frame skip behave? I can't imagine it's supposed to roll back to a few frames ago instead of just showing a still image for a moment. It just got worse: the scenery blinks on and off too.

- Any hope of getting GSdx r1873 working without DX11? It whines about a missing dll and fails to appear in the list.

- Why does interlace make such a difference if the game is CPU limited? (I can't imagine that an 8800 card fails to draw a game at 512x512!)
Reply
#5
Sure my graphic card isnt that much better than yours and it has troubles in a lot of games and I wish I could afford a better one. What I meant about your graphic card could use a boost is that just as mine it will not always cope with the game and puts a load on the cpu which is already maxed out since you have a very weak cpu, I am mostly ok since my cpu is much better, still some game dont run at full frames even on my pc.

You can get the missing dlls for gsdx at the very top left of this page, the small disk icon. Hopefully this will get you a couple of fps more but I doubt youll get full speed, no matter the settings.
Specs:
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Reply
#6
@ GamerGeek
As far as i know you cant set it to native and have texture filtering unchecked beacuse you cant change that option
[Image: 2ymccqu.jpg]
[Image: 17715.png]
Reply
#7
Gamergeek: there is no reason any 8800 can't play PS2 games at decent res for most games, and native res for anything else with full speed.

brotherlaz: Frameskip does not behave with VU Cycle steal turned on. Use one or the other, if you use both you get those graphic glitches you described.

Your problem is simply your CPU is too slow... Most PS2 games require a 3+ghz dual core to run games full speed. There are, of course, exceptions... but you're still way below what is recommended for the emulator by almost a factor of 2.
[Image: 2748844.png]
Reply
#8
(12-02-2009, 06:06 PM)diegochiha Wrote: @ GamerGeek
As far as i know you cant set it to native and have texture filtering unchecked beacuse you cant change that option

You cant change the option because it will be turned off automatically when checking native regardless of what the tick says. It's like when using a software renderer where almost everything else will be greyed except the software only options, it's just because it doesnt matter what you set the greyed options at that point.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#9
(12-02-2009, 09:33 PM)Shadow Lady Wrote:
(12-02-2009, 06:06 PM)diegochiha Wrote: @ GamerGeek
As far as i know you cant set it to native and have texture filtering unchecked beacuse you cant change that option

You cant change the option because it will be turned off automatically when checking native regardless of what the tick says. It's like when using a software renderer where almost everything else will be greyed except the software only options, it's just because it doesnt matter what you set the greyed options at that point.

Thanks shadow lady at least someone got my point
[Image: 2ymccqu.jpg]
[Image: 17715.png]
Reply
#10
I don't know. I have the EVGA GeForce 8800GTS 320MB version as well. (It is the Superclocked version.) Although I may have two of them in an SLI setup, PCSX2 does not utilize SLI. So let's say for the sake of this thread that I am running one of these cards. I am running PCSX2 with 1440x900 resolution and so far, almost every game I threw at it was running full 60fps on my card. I'm sure if I used native res on the few games that are not running full speed, I can get them to. Forget PCSX2, most PC games I threw at my rig are running fine at that resolution.

The fact of the matter is, he is using a slow CPU for this emulator. The Core 2 Duo E6300 clocks at 1.86GHZ stock. I'm also assuming that you are using the stock fan. Your only option of getting the game to run faster on your CURRENT setup would be to Overclock your CPU. The E6300 can get a decent OC, but not all CPU's can yield a good OC. If you plan on OC'ing with the stock fan, (not recommended.) Don't push the OC to more than 2.2GHZ. If you can get a good aftermarket cooler, some have gotten the E6300 to OC a 3Ghz clock. If you can get a 2.8-3Ghz OC, you should not have many problems with most games. Also be aware that when you OC, your Mainboard and RAM also has to support it. You also OC your ram when you OC your CPU. So watch your CPU temps and your ram clock speed when OC'ing.
Laptop: Apple MacBook Pro Retina 15' | Intel Core i7-4850HQ @ 2.3-3.5Ghz | Optimus Powered nVidia Geforce GT 750M (2GB GDDR5) + Intel Iris Pro Graphics | 16GB (2x8GB) DDR3 1600Mhz RAM | Intel HD Audio | Apple Magic Trackpad | Samsung 512GB PCI-E Based SSD |
Reply




Users browsing this thread: 1 Guest(s)