Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Worse MGS3 performance after upgrading E6600-E8600
#1
Hi all,

I just upgraded from E6600 to E8600 (both at stock; I'm loath to OC until I get a better cooler). After the upgrade MGS3 performance remained relatively stable, or perhaps even decreased. This suggests that the game possibly is GPU-bound instead of CPU-bound. My GPU is a Radeon HD 4850, which (from reading other posts) should be more than sufficient for this game.

Does anyone have any suggestions?

System:
Windows XP SP3
ASUS P5B Deluxe
Intel Core 2 Duo E8600 @3.33 GhZ
Radeon HD 4850
4GB OCZ Reaper DDR2 800 (PC2 6400)
Other stuff

PCSX Settings:
svn rev. 1300 (latest as of this post, unless you guys are working REALLY fast)
CPU set to "limit" (frameskip does weird things)
microVU off
GSDX Direct3D9 HW/Pixel Shader 3.0
All speed hacks on (VU Cycle Stealing at Moderate; any higher introduces bugs)

Thanks,
fraserofthenight
Reply

Sponsored links

#2
Try this game under vista in directx.10 mode at gsdx plugin.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
Reply
#3
(06-01-2009, 05:19 AM)Register Wrote: Try this game under vista in directx.10 mode at gsdx plugin.

Ick, Vista... and I was down to a 7 second startup time in XP!
Reply
#4
(06-01-2009, 05:26 AM)fraserofthenight Wrote:
(06-01-2009, 05:19 AM)Register Wrote: Try this game under vista in directx.10 mode at gsdx plugin.

Ick, Vista... and I was down to a 7 second startup time in XP!

Vista is pretty much a better operating system in every way, now.
http://www.twitch.tv/krazytrumpeter05
Want to stream your games? Let me know and I can help you get set up with Open Broadcaster Software.
Reply
#5
(06-01-2009, 05:53 AM)KrazyTrumpeter05 Wrote:
(06-01-2009, 05:26 AM)fraserofthenight Wrote:
(06-01-2009, 05:19 AM)Register Wrote: Try this game under vista in directx.10 mode at gsdx plugin.

Ick, Vista... and I was down to a 7 second startup time in XP!

Vista is pretty much a better operating system in every way, now.

eh no... just no...

However they're right this game might get quite the boost from using DX10 mode.
Reply
#6
(06-01-2009, 06:19 AM)Shadow Lady Wrote:
(06-01-2009, 05:53 AM)KrazyTrumpeter05 Wrote:
(06-01-2009, 05:26 AM)fraserofthenight Wrote:
(06-01-2009, 05:19 AM)Register Wrote: Try this game under vista in directx.10 mode at gsdx plugin.

Ick, Vista... and I was down to a 7 second startup time in XP!

Vista is pretty much a better operating system in every way, now.

eh no... just no...

However they're right this game might get quite the boost from using DX10 mode.
Vista's so much better than XP
AMD Phenom II 940 @ 3.6GHZ, 4GB PC8500 @ 1100MHZ, 4870x2 @ Stock.
Reply
#7
(06-01-2009, 09:15 AM)Sythedragon Wrote: Vista's so much better than XP

Even if it is, it's better to recommend waiting for Win7 than to use Vista. this isn't an argument directed at you BTW, it's just something people don't really think about.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#8
fraserofthenight:

performance shouldn't decrease with a faster CPU.
make sure to turn-off any cpu powersaving/voltage regulating options set in your BIOS.
make sure your temps are okay too.

next, download the latest pcsx2 and make sure you have the MTGS checkbox checked in the CPU options (as well as all other checkboxes in there except for microVU ones); then get the latest directX and the latest GSdx.

if you think your GPU may be the problem, make sure to check the native checkbox in gsdx to see if speed is improved.
Check out my blog: Trashcan of Code
Reply
#9
To the OP, download the Windows 7 latest beta, use DX10 on that.
AMD Phenom II 940 @ 3.6GHZ, 4GB PC8500 @ 1100MHZ, 4870x2 @ Stock.
Reply
#10
as cotton says, there is a known problem with ATI's and GSDX for some unknown reason, fixes can vary from putting it in native to using full screen mode. You could even try software mode if you get desperate!
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)