Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
X-men Legends 2 crashing
#1
Hello, The game ran just fine. It just if I use a few abilities, it will crash the game and the emulator. Here the emulog

Code:
PCSX2 1.2.1.r5873 - compiled on Feb  3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
    Operating System =  Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
    Physical RAM     =  16333 MB
    CPU name         =  Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz
    Vendor/Model     =  GenuineIntel (stepping 03)
    CPU speed        =  3.398 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7fdafbbf
    x86EFlags        =  2c100000

x86 Features Detected:
    MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. FMA

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\gsdx32-avx-r5875.dll
Windows 6.1.7601 (Service Pack 1 1.0)
    Binding  PAD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\lilypad-r5875.dll
    Binding SPU2: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\spu2-x-r5875.dll
    Binding CDVD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\cdvdGigaherz.dll
    Binding  USB: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\USBnull.dll
    Binding   FW: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\FWnull.dll
    Binding DEV9: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 152ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
* SPU2-X: Enumerating PortAudio devices:
*** Device 0: 'Primary Sound Driver' (Windows DirectSound)
*** Device 1: 'Speakers (Realtek High Definition Audio)' (Windows DirectSound)
*** Device 2: 'SMBX2431-4 (2- NVIDIA High Definition Audio)' (Windows DirectSound)
*** Device 3: 'Speakers (Realtek High Definition Audio)' (Windows WASAPI)
*** Device 4: 'SMBX2431-4 (2- NVIDIA High Definition Audio)' (Windows WASAPI)
*** Device 5: 'Output (NVIDIA High Definition Audio)' (Windows WDM-KS)
*** Device 6: 'Speakers (Realtek HD Audio output)' (Windows WDM-KS)
*** Device 7: 'SPDIF Out (Realtek HDA SPDIF Out)' (Windows WDM-KS)
    Opening CDVD
isoFile open ok: D:\ISOs\PS2\xmenlegends2riseofA.ISO
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (858608 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0: C:\Users\XX\Documents\PCSX2\memcards\my memory card.ps2
McdSlot 1: C:\Users\XX\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v02.00(14/06/2004)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_211.38;1
(SYSTEM.CNF) Software version = 1.03
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_211.38;1) Game CRC = 0x0E707DA4, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_211.38;1
(SYSTEM.CNF) Software version = 1.03
(SYSTEM.CNF) Disc region type = NTSC
Found Cheats file: '0E707DA4.pnach'
Loaded 4 Cheats from '0E707DA4.pnach'
Overall 4 Cheats loaded
(EE pc:002B76B4) TLB Miss, addr=0x2000020 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000010 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000050 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000040 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000080 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000070 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20000b0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20000a0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20000e0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20000d0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000110 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000100 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000140 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000130 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000170 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000160 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20001a0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000190 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20001d0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20001c0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000200 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20001f0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000230 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000220 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000260 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000250 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000290 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000280 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20002c0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20002b0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20002f0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20002e0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000320 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000310 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000350 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000340 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000380 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000370 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20003b0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20003a0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20003e0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20003d0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000410 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000400 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000440 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000430 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000470 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000460 [load]
(EE pc:002B76B4) TLB Miss, addr=0x20004a0 [load]
(EE pc:002B76B4) TLB Miss, addr=0x2000490 [load]
..\..\FiFo.cpp(47) : assertion failed:
    Function:  ReadFIFO_VIF1
    Thread:    EE Core
    Condition: vif1Regs.stat.FQC != 0
    Message:   FQC = 0 on VIF FIFO READ!

[00] 0x016B16B1                                  
[01] 0x03210112                                  
[02] 0x01361005                                  
[03] 0x013E4FDE                                  
[04] 0x0142B7FA                                  
[05] 0x013CFAA1                                  
[06] 0x013CFA1B                                  
[07] 0x013CF969                                  
[08] pthread_setcanceltype                      
[09] endthreadex                                
[10] endthreadex                                
[11] BaseThreadInitThunk                        
[12] RtlInitializeExceptionChain                
[13] RtlInitializeExceptionChain                

Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
    Closing PAD
    Closing GS
Plugins closed successfully.
Shutting down plugins...

Other game do not have any problem. Help me out how to solve this issue?

My Spec is
Code:
Operating System
            Windows 7 Ultimate 64-bit SP1
        CPU
            Intel Core i5 4670K @ 3.40GHz    91 °F
            Haswell 22nm Technology
        RAM
            16.0GB Dual-Channel DDR3 @ 799MHz (11-11-11-28)
        Motherboard
            MSI Z97-GD65 GAMING (MS-7845) (SOCKET 0)    92 °F
        Graphics
            SMBX2431 (1920x1080@60Hz)
            4095MB NVIDIA GeForce GTX 760 (EVGA)    90 °F
            4095MB NVIDIA GeForce GTX 760 (EVGA)    88 °F
            ForceWare version: 347.88
            SLI Enabled
        Storage
            931GB Hitachi HDS721010CLA332 SCSI Disk Device (SATA)    92 °F
            931GB Western Digital WDC WD1003FZEX-00MK2 SCSI Disk Device (SATA)    90 °F
            58GB SanDisk SanDisk Ultra USB Device (USB)
        Optical Drives
            ATAPI iHAS324 B ATA Device
        Audio
            Realtek High Definition Audio
Reply

Sponsored links

#2
There's a lot of TLB misses there, can you try reripping your iso with IMGBurn on lowest speed? Also, make sure the dvd is clean beforehand
Reply
#3
probably deactivating the cheats should work... (avoid using savestates until the problem is solved)
Reply
#4
(06-07-2015, 09:10 PM)Rassane Wrote: There's a lot of TLB misses there, can you try reripping your iso with IMGBurn on lowest speed? Also, make sure the dvd is clean beforehand

I tried again with the lowest burn and it still crashing the game. I decided to try without cheat. So I disabled the cheat and it is working without any issue. apparently the cheat is causing the problem.

Didn't see your post, Willkuer. Yea I figured it was the cheat the causing those problem. I noticed this issue when I have infinite health enabled and it is not working. that prompt me to try without cheat
Reply
#5
can you please attach the pnach file?
Reply
#6
(06-07-2015, 10:01 PM)willkuer Wrote: can you please attach the pnach file?

Sure. The code is based on Action Replay MAX and I used Mutli Converter to do the job for me.

After the issue, I changed the code to Codebreaker and it working just fine without any issue.

The attached pnach file is AR code.


Attached Files
.pnach   0E707DA4.pnach (Size: 314 bytes / Downloads: 69)
Reply
#7
Give these a try.

Code:
gametitle=X-Men Legends II - Rise of Apocalypse (NTSC-U)

// Infinite Energy
patch=1,EE,203CEE3C,extended,E4810244

// Max/Infinite Health Packs
patch=1,EE,0079A130,extended,00000063

// Max/Infinite Energy Packs
patch=1,EE,0079A154,extended,00000063

// Max/Infinite Tech Bits
patch=1,EE,2079A5A0,extended,000F423F

[Edit] Oh you got them working already lol, oops.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#8
(06-08-2015, 12:00 AM)Ryudo Wrote: Give these a try.

Code:
gametitle=X-Men Legends II - Rise of Apocalypse (NTSC-U)

// Infinite Energy
patch=1,EE,203CEE3C,extended,E4810244

// Max/Infinite Health Packs
patch=1,EE,0079A130,extended,00000063

// Max/Infinite Energy Packs
patch=1,EE,0079A154,extended,00000063

// Max/Infinite Tech Bits
patch=1,EE,2079A5A0,extended,000F423F

[Edit] Oh you got them working already lol, oops.

Yea I already did. I found that some game do not play nice with certain code. Like Castlevania Curse of Darkness will cause graphic issue with Codebreaker while ARMax work great with it. And X-men Legends 2 will crash with ARMax while Codebreaker work great with it. I don't believe it the code problem. I believe it all down to how PCSX2CE decrypt it. Not all software is perfect. But it a good thing that we have choices to use if one thing is not working correctly with it.
Reply




Users browsing this thread: 1 Guest(s)