Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
X-men Legends - low FPS! PCSX2 0.9.8
#1
Hey, for some reason once I get in-game with X-men Legends the FPS lowers down to around 15 - 22. Any way in which I can fix this? Other games like KH Re: COM reaches a good amount [although sometimes it can go quite low in certain cutscenes...], as a few other games.

Computer info:

Acer Aspire 6920
Windows index rating: 4.6
Intel® Core™ Due CPU T5750 @ 2.00 GHz 2.00 Ghz
Ram: 3GB
32-bit operating system

I am using all the default settings for the PCSX2 0.9.8. Apart from the GS which is the GSdx 4600 (MSVC 15.00, SSSE3) 0.1.16.


Is my computer simply not powered enough for this particular game? XD

Thanks in advance for any help. ^_^
Reply

Sponsored links

#2
Low cpu clock speed and I guess that this laptop is using a integrated graphics chipset? If so, then those 2 things I listed is your problem. Different games have different hardware specs requirements, however you could try some speedhacks by moving the EE and VU slider to the middle and enable some "other hacks".
Reply
#3
Use the "VU cycle stealing" speedhack, gives a bit of a speedup in this game.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
Ahh thank you! I put both VU and EE to middle like said and it was a lot better. Reaching 30-40 now and 50 at some parts. Much better. XD If I put VU cycle steaing up even more do you think it will speed it up more, Shadow lady?

Reply
#5
Yes, but at some points it will feel like it's skippping, just try it and see if it works for you like that Tongue
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
That helped thanks! Get solid 40fps and sometimes more. Which is a lot more playable! XD Though, yeah it skips some dialogue occasionally. XD
Reply
#7
What I meant by skippy was you get 60fps but looks more like 20/30 or so even tho it's still full speed Tongue2
The dialogue problem is because of the sound plugin, you could try with ZeroSPU2 from older releases...
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#8
Ahh. I see. Okay, I'll try that. XD
Reply




Users browsing this thread: 1 Guest(s)